Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726604 - www-client/chromium-83.0.4103.61 - error: requested alignment is not an integer constant
Summary: www-client/chromium-83.0.4103.61 - error: requested alignment is not an integ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chromium Project
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2020-06-01 07:10 UTC by Fabio Rossi
Modified: 2020-06-04 14:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
chromium-83.0.4103.61:20200528-175525.log.gz (chromium-83.0.4103.61:20200528-175525.log.gz,6.21 KB, application/gzip)
2020-06-01 07:10 UTC, Fabio Rossi
Details
emerge-info.txt.gz (emerge-info.txt.gz,7.56 KB, application/gzip)
2020-06-01 07:11 UTC, Fabio Rossi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Rossi 2020-06-01 07:10:05 UTC
I am attaching a shorter version of the full build log file. I suspect the issue is related to gcc-8 because the build succeeds with gcc-9
Comment 1 Fabio Rossi 2020-06-01 07:10:55 UTC
Created attachment 642972 [details]
chromium-83.0.4103.61:20200528-175525.log.gz
Comment 2 Fabio Rossi 2020-06-01 07:11:28 UTC
Created attachment 642974 [details]
emerge-info.txt.gz
Comment 3 Stephan Hartmann gentoo-dev 2020-06-01 07:53:09 UTC
It is a gcc bug: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=94929

But I try to add a patch.
Comment 4 Fabio Rossi 2020-06-01 07:57:51 UTC
thanks for the link, as it's a gcc-8 regression probably it's better to patch gcc instead of chromium
Comment 5 Samuel Bernardo 2020-06-02 22:11:26 UTC
I have also the same error with gcc-8.
Comment 6 Larry the Git Cow gentoo-dev 2020-06-04 14:47:03 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a537d59b37b14d88b8cb5e4ad1020d0f1645a601

commit a537d59b37b14d88b8cb5e4ad1020d0f1645a601
Author:     Stephan Hartmann <stha09@googlemail.com>
AuthorDate: 2020-06-04 06:32:23 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2020-06-04 14:46:54 +0000

    www-client/chromium: stable channel bump to 83.0.4103.97
    
    Bug: https://bugs.gentoo.org/727012
    Closes: https://bugs.gentoo.org/726604
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>
    Closes: https://github.com/gentoo/gentoo/pull/16065

 www-client/chromium/Manifest                       |   1 +
 www-client/chromium/chromium-83.0.4103.97.ebuild   | 820 +++++++++++++++++++++
 .../files/chromium-83-gcc-compatibility.patch      |  25 +
 3 files changed, 846 insertions(+)