Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726564 - app-emulation/firecracker does not respect LDFLAGS
Summary: app-emulation/firecracker does not respect LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2020-06-01 06:32 UTC by Agostino Sarubbo
Modified: 2020-08-29 08:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,78.74 KB, text/plain)
2020-06-01 06:32 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-06-01 06:32:51 UTC
This is an auto-filed bug because app-emulation/firecracker does not respect LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-06-01 06:32:56 UTC
Created attachment 642964 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-08-29 08:17:16 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7a918d0daba55e740540a7dd5190e7c5c98b609b

commit 7a918d0daba55e740540a7dd5190e7c5c98b609b
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2020-08-29 08:12:45 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2020-08-29 08:17:15 +0000

    app-emulation/firecracker: Ignore all flags
    
    Closes: https://bugs.gentoo.org/726564
    Closes: https://bugs.gentoo.org/728024
    
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>

 app-emulation/firecracker/firecracker-0.21.1-r1.ebuild | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)