Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726340 - app-emulation/virtualbox-{5.2.42,6.0.22,6.1.10} bump request
Summary: app-emulation/virtualbox-{5.2.42,6.0.22,6.1.10} bump request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-31 06:18 UTC by Vasilis Lourdas
Modified: 2020-06-13 21:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vasilis Lourdas 2020-05-31 06:18:20 UTC
VirtualBox 6.1.8 (released May 15 2020)

This is a maintenance release. The following items were fixed and/or added:

GUI: Fix several layout and mouse position handling bugs with soft keyboard
GUI: Fixed crash on last VM removed (6.1.4 regression; bug #19568, #19525, #19506, #19490, #19481, #19397)
GUI and API: Allow renaming VMs which are in saved state
Serial: Fixed slow guest output when using the TCP server mode without anyone being connected
Guest Additions: Restored 'VBoxClient--checkhostversion' functionality (6.1.0 regression; bug #19470)
Guest Additions: Fixed resizing and multi monitor handling for X11 guests. (6.1.0 regression; bug #19496)
Guest Additions: Build problems fix with Oracle Linux 8.2 (Red Hat compatible kernel) / Red Hat Enterprise Linux 8.2 / CentOS 8.2 (bug #19391)
Guest Control/VBoxManage: Fixed handling of multiple environment variables supplied to 'VBoxManage guestcontrol VM run' (6.1.6/6.0.20 regression; bug #19518)
Guest Control: Implemented support for long(er) command lines
Guest Control: Various stability improvements
Comment 1 Adrien Dessemond 2020-06-03 16:29:26 UTC
There is an issue with Qt 5.15, see:
https://www.virtualbox.org/ticket/19637

The changes to apply are also documented.
Comment 2 jospezial 2020-06-06 14:01:16 UTC
VirtualBox 6.1.10 (released June 05 2020)

This is a maintenance release. The following items were fixed and/or added:

    GUI: Fixed crash when using Qt on Xwayland sessions (bug #19583)
    GUI: Fixed mouse pointer doesn't work properly in Windows guests when scaling is on (bug #19597)
    VBoxManage: Fixed crash of 'VBoxManage internalcommands repairhd' when processing invalid input (bug #19579)
    Settings: disable audio input and audio output by default for new VMs (bug #19527)
    Guest Additions: Fixed resizing and multi monitor handling for Wayland guests. (bug #19496)
    Guest Additions: Fixed VBoxClient error: The parent session seems to be non-X11. (bug #19590)
    Linux host and guest: Linux kernel version 5.7 support. (bug #19516)
Comment 3 Adrien Dessemond 2020-06-13 02:17:43 UTC
https://www.virtualbox.org/ticket/19637 is still a valid issue in 6.1.10.
Comment 4 Larry the Git Cow gentoo-dev 2020-06-13 21:06:29 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ab5b46fcf3d20f30ff6cff94cabfa9c32142014b

commit ab5b46fcf3d20f30ff6cff94cabfa9c32142014b
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2020-06-13 21:06:11 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2020-06-13 21:06:24 +0000

    virtualbox packages: Bump to versions 5.2.42, 6.0.22 and 6.1.10
    
    Bug: https://bugs.gentoo.org/707082
    Closes: https://bugs.gentoo.org/726340
    Closes: https://bugs.gentoo.org/727292
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 app-emulation/virtualbox-additions/Manifest        |   3 +
 .../virtualbox-additions-5.2.42.ebuild             |  33 ++
 .../virtualbox-additions-6.0.22.ebuild             |  34 ++
 .../virtualbox-additions-6.1.10.ebuild             |  34 ++
 app-emulation/virtualbox-bin/Manifest              |  10 +
 .../virtualbox-bin-5.2.42.137960.ebuild            | 287 ++++++++++++
 .../virtualbox-bin-6.0.22.137980.ebuild            | 292 ++++++++++++
 .../virtualbox-bin-6.1.10.138449.ebuild            | 292 ++++++++++++
 app-emulation/virtualbox-extpack-oracle/Manifest   |   3 +
 .../virtualbox-extpack-oracle-5.2.42.137960.ebuild |  42 ++
 .../virtualbox-extpack-oracle-6.0.22.137980.ebuild |  43 ++
 .../virtualbox-extpack-oracle-6.1.10.138449.ebuild |  43 ++
 app-emulation/virtualbox-guest-additions/Manifest  |   5 +
 .../virtualbox-guest-additions-5.2.42.ebuild       | 232 ++++++++++
 .../virtualbox-guest-additions-6.0.22.ebuild       | 219 +++++++++
 .../virtualbox-guest-additions-6.1.10.ebuild       | 218 +++++++++
 app-emulation/virtualbox-modules/Manifest          |   3 +
 .../virtualbox-modules-5.2.42.ebuild               |  59 +++
 .../virtualbox-modules-6.0.22.ebuild               |  55 +++
 .../virtualbox-modules-6.1.10.ebuild               |  55 +++
 app-emulation/virtualbox/Manifest                  |   7 +-
 app-emulation/virtualbox/virtualbox-5.2.42.ebuild  | 493 ++++++++++++++++++++
 app-emulation/virtualbox/virtualbox-6.0.22.ebuild  | 507 +++++++++++++++++++++
 app-emulation/virtualbox/virtualbox-6.1.10.ebuild  | 505 ++++++++++++++++++++
 app-emulation/virtualbox/virtualbox-6.1.6.ebuild   |   2 +-
 25 files changed, 3474 insertions(+), 2 deletions(-)