Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726288 - x11-misc/xtitle calls ld directly
Summary: x11-misc/xtitle calls ld directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-30 11:26 UTC by Agostino Sarubbo
Modified: 2021-04-15 06:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.90 KB, text/plain)
2020-05-30 11:26 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-30 11:26:03 UTC
This is an auto-filed bug because x11-misc/xtitle calls ld directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different linker implementation (like llvm-link) by setting the LD variable. So this issue has been reproduced by setting the LD variable to x86_64-pc-linux-gnu-ld and by removing the /usr/bin/ld binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-30 11:26:08 UTC
Created attachment 642756 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2021-04-15 06:39:13 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=00cd446b3c4dfad221ace9521636082e35318cbb

commit 00cd446b3c4dfad221ace9521636082e35318cbb
Author:     Ionen Wolkens <sudinave@gmail.com>
AuthorDate: 2021-04-14 13:17:09 +0000
Commit:     Joonas Niilola <juippis@gentoo.org>
CommitDate: 2021-04-15 06:38:57 +0000

    x11-misc/xtitle: fix build with -native-symlinks
    
    Closes: https://bugs.gentoo.org/726288
    Signed-off-by: Ionen Wolkens <sudinave@gmail.com>
    Signed-off-by: Joonas Niilola <juippis@gentoo.org>

 x11-misc/xtitle/xtitle-1.0.4.ebuild | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)