Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 726014 - sys-kernel/dracut-crypt-ssh does not respect LDFLAGS
Summary: sys-kernel/dracut-crypt-ssh does not respect LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jakov Smolic
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2020-05-29 06:56 UTC by Agostino Sarubbo
Modified: 2021-04-03 12:31 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,12.59 KB, text/plain)
2020-05-29 06:56 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-29 06:56:12 UTC
This is an auto-filed bug because sys-kernel/dracut-crypt-ssh does not respect LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to see this bug as an hint to hide the QA warning where is not possible to respect LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-29 06:56:18 UTC
Created attachment 642442 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2021-04-03 12:31:28 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f2db8522dc3761c94b109a5c3338b82ad02cf835

commit f2db8522dc3761c94b109a5c3338b82ad02cf835
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2021-04-03 12:30:47 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2021-04-03 12:30:47 +0000

    sys-kernel/dracut-crypt-ssh: Respect CC/LDFLAGS
    
    Closes: https://bugs.gentoo.org/726014
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: David Seifert <soap@gentoo.org>

 .../dracut-crypt-ssh/dracut-crypt-ssh-1.0.7.ebuild     | 11 +++++++++--
 .../files/dracut-crypt-ssh-1.0.7-ldflags.patch         | 18 ++++++++++++++++++
 2 files changed, 27 insertions(+), 2 deletions(-)