Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725984 - dev-python/python-language-server-0.32.0: The 'parso>=0.7.0' distribution was not found and is required by jedi
Summary: dev-python/python-language-server-0.32.0: The 'parso>=0.7.0' distribution was...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2020-05-29 06:51 UTC by phkb
Modified: 2020-06-02 08:52 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
pyls traceback (traceback,1.71 KB, text/plain)
2020-05-29 06:51 UTC, phkb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description phkb 2020-05-29 06:51:02 UTC
Created attachment 642410 [details]
pyls traceback

pyls fails to start, saying jedi needs parso>=0.7.0. However I can import jedi fine from python.

I have the following package version installed:
dev-python/python-language-server-0.32.0
dev-python/jedi-0.17.0
dev-python/parso-0.6.2

I attached the full traceback I get when I run pyls.
Comment 1 Andrew Ammerlaan 2020-06-01 09:40:09 UTC
This is a bug in the jedi ebuild, not in the pyls ebuild. According to jedi upstream requirements.txt jedi should depend on parso>=0.7.0: https://github.com/davidhalter/jedi/blob/master/requirements.txt