Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725978 - sys-fs/mergerfs calls ar directly
Summary: sys-fs/mergerfs calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Piotr Karbowski
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-29 06:50 UTC by Agostino Sarubbo
Modified: 2020-08-08 20:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,41.60 KB, text/plain)
2020-05-29 06:50 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-29 06:50:08 UTC
This is an auto-filed bug because sys-fs/mergerfs calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-29 06:50:14 UTC
Created attachment 642404 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-08-08 20:00:38 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4862dc8bd86bb9810de3088b4ffacc42015736f0

commit 4862dc8bd86bb9810de3088b4ffacc42015736f0
Author:     Piotr Karbowski <slashbeast@gentoo.org>
AuthorDate: 2020-08-08 19:59:01 +0000
Commit:     Piotr Karbowski <slashbeast@gentoo.org>
CommitDate: 2020-08-08 20:00:27 +0000

    sys-fs/mergerfs: 2.30.0 bump
    
    Version bump; Now uses environmental provided AR, CFLAGS, CXXFLAGS and LDFLAGS.
    
    Closes: https://bugs.gentoo.org/725978
    Closes: https://bugs.gentoo.org/728158
    Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>

 sys-fs/mergerfs/Manifest                           |  1 +
 ...akefiles-fixes-ar-cflags-cxxflags-ldflags.patch | 83 ++++++++++++++++++++++
 sys-fs/mergerfs/mergerfs-2.30.0.ebuild             | 56 +++++++++++++++
 3 files changed, 140 insertions(+)