Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725836 - sys-boot/sgibootcd does not respect LDFLAGS
Summary: sys-boot/sgibootcd does not respect LDFLAGS
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: MIPS Porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2020-05-28 07:29 UTC by Agostino Sarubbo
Modified: 2020-10-16 00:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,12.84 KB, text/plain)
2020-05-28 07:29 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-28 07:29:42 UTC
This is an auto-filed bug because sys-boot/sgibootcd does not respect LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to see this bug as an hint to hide the QA warning where is not possible to respect LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-28 07:29:48 UTC
Created attachment 642300 [details]
build.log

build log and emerge --info
Comment 2 Joshua Kinard gentoo-dev 2020-10-16 00:12:56 UTC
This package is for an extremely small utility only used on SGI Boot CDs, which behave more like disk partitions burned to optical media than classic ISO9660 format.  The code is known to have stylistic issues and needs to be refactored, but it's far down on my TODO list to whenever I get around to attempting bootable SGI media again.