Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 72553 - ebuild request for filedupe
Summary: ebuild request for filedupe
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-26 07:33 UTC by Mitchell
Modified: 2005-12-16 20:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mitchell 2004-11-26 07:33:01 UTC
Filedupe is a utility to assist in finding any duplicates as you
accumulate files. It stores md5 hashes of all the files seen in a
system wide database (/var/db/filedupe.db) so it can quickly spot any
duplicates.

WWW: http://sammy.net/~sammy/hacks/

Reproducible: Always
Steps to Reproduce:
Comment 1 Dan 2004-11-26 07:56:35 UTC
It wont even compile for me... have you got it to work?

gcc -g -o filedupe md5.o filedupe.o -lgdbm
filedupe.o(.text+0x3e8): In function `lookup':
/home/hydrogen/filedupe-1.1/filedupe.c:165: undefined reference to `dbm_open'
filedupe.o(.text+0x41d):/home/hydrogen/filedupe-1.1/filedupe.c:169: undefined reference to `dbm_fetch'
filedupe.o(.text+0x431):/home/hydrogen/filedupe-1.1/filedupe.c:171: undefined reference to `dbm_close'
filedupe.o(.text+0x448):/home/hydrogen/filedupe-1.1/filedupe.c:174: undefined reference to `dbm_close'
filedupe.o(.text+0x4f0): In function `addfile':
/home/hydrogen/filedupe-1.1/filedupe.c:207: undefined reference to `dbm_open'
filedupe.o(.text+0x532):/home/hydrogen/filedupe-1.1/filedupe.c:214: undefined reference to `dbm_fetch'
filedupe.o(.text+0x5e4):/home/hydrogen/filedupe-1.1/filedupe.c:231: undefined reference to `dbm_store'
filedupe.o(.text+0x5ef):/home/hydrogen/filedupe-1.1/filedupe.c:232: undefined reference to `dbm_close'
collect2: ld returned 1 exit status
make: *** [filedupe] Error 1
Comment 2 Andrej Kacian (RETIRED) gentoo-dev 2004-11-26 12:29:35 UTC
Looks like some missing dependency not caught by the configure script. Report upstream.
Comment 3 Mitchell 2004-12-12 20:41:09 UTC
Did you try setting DBNAME in filedupe.c like the README said to do?  I tried setting an absolute path to a file and it still did not fix the problem.  If you look at http://woodsite.net/ports/sysutils/filedupe/files/, you will see that FreeBSD made two changes to get this package to work.  The first was they changed the Makefile then they also changed filedupe.c and put the absolute path to the database file.

Hope this helps.
Comment 4 Aaron Walker (RETIRED) gentoo-dev 2004-12-13 02:34:43 UTC
This looks like a good candidate for shell-tools herding.  Mitchell, have you used app-misc/fdupes at all?  It supposedly does the same thing, going by the apps' description.  I'll have to sit down and compare the two, but unless they are identical feature-wise, I'll add it as soon as I get some free time.
Comment 5 Ciaran McCreesh 2005-12-16 19:14:07 UTC
Think we'll WONTFIX this one. fdupes is considerably more featureful.