Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725488 - sci-libs/linux-gpib-modules calls cc directly
Summary: sci-libs/linux-gpib-modules calls cc directly
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-26 09:19 UTC by Agostino Sarubbo
Modified: 2020-05-26 14:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,11.45 KB, text/plain)
2020-05-26 09:19 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-26 09:19:39 UTC
This is an auto-filed bug because sci-libs/linux-gpib-modules calls cc directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different CC implementation (like clang) by setting the CC variable. So this issue has been reproduced by setting the CC variable to x86_64-pc-linux-gnu-gcc and by removing the /usr/bin/cc - /usr/bin/gcc binaries.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-26 09:19:44 UTC
Created attachment 641914 [details]
build.log

build log and emerge --info
Comment 2 Andreas K. Hüttel gentoo-dev 2020-05-26 14:42:56 UTC
sci-libs/linux-gpib-modules uses the build system of the installed kernel sources. So it'll use the CC that the kernel was configured for.