Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725280 - x11-libs/xpa calls ar directly
Summary: x11-libs/xpa calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci Astronomy Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-25 10:09 UTC by Agostino Sarubbo
Modified: 2021-03-20 11:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,16.32 KB, text/plain)
2020-05-25 10:09 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-25 10:09:42 UTC
This is an auto-filed bug because x11-libs/xpa calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-25 10:09:47 UTC
Created attachment 641682 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2021-03-20 11:32:55 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=76b33c54c4ad71002f065a5b89982601e76befb4

commit 76b33c54c4ad71002f065a5b89982601e76befb4
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2021-03-20 11:32:41 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2021-03-20 11:32:41 +0000

    x11-libs/xpa: Port to EAPI 7
    
    Closes: https://bugs.gentoo.org/725280
    Package-Manager: Portage-3.0.17, Repoman-3.0.2
    Signed-off-by: David Seifert <soap@gentoo.org>

 x11-libs/xpa/files/xpa-2.1.18-makefile.patch | 44 ++++++++++++++++++++++++----
 x11-libs/xpa/xpa-2.1.18.ebuild               | 22 +++++++++-----
 2 files changed, 52 insertions(+), 14 deletions(-)