Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725228 - net-wireless/bss does not respect CFLAGS
Summary: net-wireless/bss does not respect CFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords: PullRequest
: 438046 (view as bug list)
Depends on:
Blocks: cflags
  Show dependency tree
 
Reported: 2020-05-25 07:21 UTC by Agostino Sarubbo
Modified: 2021-05-04 22:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,11.87 KB, text/plain)
2020-05-25 07:21 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-25 07:21:51 UTC
This is an auto-filed bug because net-wireless/bss does not respect CFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-25 07:21:56 UTC
Created attachment 641578 [details]
build.log

build log and emerge --info
Comment 2 Jakov Smolic 2021-04-29 23:04:45 UTC
*** Bug 438046 has been marked as a duplicate of this bug. ***
Comment 3 Larry the Git Cow gentoo-dev 2021-05-04 22:17:31 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0e447f8ce622c2aa8af0edc96f3a9fec85746fa0

commit 0e447f8ce622c2aa8af0edc96f3a9fec85746fa0
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2021-04-29 23:04:55 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-05-04 22:17:12 +0000

    net-wireless/bss: Respect CFLAGS
    
    Closes: https://bugs.gentoo.org/725228
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: Sam James <sam@gentoo.org>

 .../bss/{bss-0.8-r1.ebuild => bss-0.8-r2.ebuild}   | 18 +++++-------
 net-wireless/bss/files/bss-0.8-Makefile.patch      | 34 ++++++++++++++++++++++
 2 files changed, 41 insertions(+), 11 deletions(-)