Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 725220 - net-misc/jwhois calls ar directly
Summary: net-misc/jwhois calls ar directly
Status: RESOLVED DUPLICATE of bug 446472
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-25 07:20 UTC by Agostino Sarubbo
Modified: 2020-09-19 22:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,15.91 KB, text/plain)
2020-05-25 07:20 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-25 07:20:29 UTC
This is an auto-filed bug because net-misc/jwhois calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-25 07:20:34 UTC
Created attachment 641570 [details]
build.log

build log and emerge --info
Comment 2 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2020-09-19 22:33:09 UTC

*** This bug has been marked as a duplicate of bug 446472 ***