Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 724942 - net-dns/maradns does not respect CFLAGS/LDFLAGS
Summary: net-dns/maradns does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Piotr Karbowski
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: cflags ldflags 735390
  Show dependency tree
 
Reported: 2020-05-24 08:10 UTC by Agostino Sarubbo
Modified: 2021-05-04 22:17 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,22.66 KB, text/plain)
2020-05-24 08:10 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-24 08:10:35 UTC
This is an auto-filed bug because net-dns/maradns does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches" and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-24 08:10:40 UTC
Created attachment 641308 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2021-05-04 22:17:42 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6f91d81f5e55ca9b74942e1808173c111c69dbf9

commit 6f91d81f5e55ca9b74942e1808173c111c69dbf9
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2021-04-29 23:41:46 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-05-04 22:17:10 +0000

    net-dns/maradns: Respect CFLAGS/LDFLAGS
    
    Closes: https://bugs.gentoo.org/724942
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: Sam James <sam@gentoo.org>

 net-dns/maradns/files/maradns-3.5.0005-flags.patch | 28 ++++++++++++++++++++++
 net-dns/maradns/maradns-3.5.0005.ebuild            | 21 +++++++++-------
 2 files changed, 41 insertions(+), 8 deletions(-)