Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 724830 - media-video/vdr2jpeg does not respect LDFLAGS
Summary: media-video/vdr2jpeg does not respect LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Joerg Bornkessel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2020-05-23 17:41 UTC by Agostino Sarubbo
Modified: 2020-06-07 19:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,8.55 KB, text/plain)
2020-05-23 17:41 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-23 17:41:40 UTC
This is an auto-filed bug because media-video/vdr2jpeg does not respect LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to see this bug as an hint to hide the QA warning where is not possible to respect LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-23 17:41:45 UTC
Created attachment 641216 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-06-07 19:21:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1aa526df1dc117420674db2140566ae3c7525494

commit 1aa526df1dc117420674db2140566ae3c7525494
Author:     Joerg Bornkessel <hd_brummy@gentoo.org>
AuthorDate: 2020-06-07 19:21:13 +0000
Commit:     Joerg Bornkessel <hd_brummy@gentoo.org>
CommitDate: 2020-06-07 19:21:13 +0000

    media-video/vdr2jpeg: does not respect LDFLAGS
    
    Closes: https://bugs.gentoo.org/724830
    Package-Manager: Portage-2.3.90, Repoman-2.3.20
    Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>

 .../vdr2jpeg/{vdr2jpeg-0.2.0-r1.ebuild => vdr2jpeg-0.2.0-r2.ebuild}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)