Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 724812 - media-gfx/iscan-plugin-network-nt does not respect CFLAGS/LDFLAGS
Summary: media-gfx/iscan-plugin-network-nt does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-05-23 17:39 UTC by Agostino Sarubbo
Modified: 2020-10-29 19:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.26 KB, text/plain)
2020-05-23 17:39 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-23 17:39:11 UTC
This is an auto-filed bug because media-gfx/iscan-plugin-network-nt does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches" and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-23 17:39:16 UTC
Created attachment 641192 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-10-29 19:22:29 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=75ee5760ed123874117f7dc33937a8251866d7d2

commit 75ee5760ed123874117f7dc33937a8251866d7d2
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2020-10-29 19:22:04 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2020-10-29 19:22:04 +0000

    media-gfx/iscan-plugin-network-nt: Set QA_PREBUILT
    
    Closes: https://bugs.gentoo.org/724812
    Package-Manager: Portage-3.0.8, Repoman-3.0.2
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild | 2 ++
 1 file changed, 2 insertions(+)