Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 724286 - dev-util/pycharm-professional does not respect CFLAGS/LDFLAGS
Summary: dev-util/pycharm-professional does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-05-20 08:10 UTC by Agostino Sarubbo
Modified: 2020-07-15 07:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,16.09 KB, text/plain)
2020-05-20 08:11 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-20 08:10:55 UTC
This is an auto-filed bug because dev-util/pycharm-professional does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches" and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-20 08:11:02 UTC
Created attachment 640486 [details]
build.log

build log and emerge --info
Comment 2 Aliaksei Urbanski 2020-07-13 09:29:50 UTC
Hello Agostino,

Excuse me, but I believe this auto-filed bug is nonsense.
How should precompiled proprietary application written in Java respect CFLAGS/LDFLAGS?
Do I not know or miss something?
Comment 3 Agostino Sarubbo gentoo-dev 2020-07-13 09:37:30 UTC
(In reply to Aliaksei Urbanski from comment #2)
> Hello Agostino,
> 
> Excuse me, but I believe this auto-filed bug is nonsense.
> How should precompiled proprietary application written in Java respect
> CFLAGS/LDFLAGS?
> Do I not know or miss something?

You miss the NOTE in comment 0