Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 72410 - openafs will not compile using gcc 3.4.3
Summary: openafs will not compile using gcc 3.4.3
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Stefaan De Roeck (RETIRED)
Depends on:
Reported: 2004-11-24 16:28 UTC by John Daschbach
Modified: 2005-12-13 00:34 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description John Daschbach 2004-11-24 16:28:48 UTC
When I try and emerge openafs the build fails with a gcc error message indicating a compile problem.  I have had openafs installed before, but it will no longer build.  I suspect it has to do with a change in gcc since I sucessfully compile openafs.  However, I upgraded the kernel and openafs no longer worked so I unmerged it and then tried to emerge openafs.  

I have tried 2 ebuilds, the current 1.2.11 and the older 1.2.10-r1 build.  

The problem appears to be with the current gcc.  I get the same error trying to compile outside of portage from the original source from

Reproducible: Always
Steps to Reproduce:
1. emerge openafs
Actual Results:  
../afs/osi_vnodeops.c: In function `afs_linux_readpage':
../afs/../afs/../afs/../afs/osi_prototypes.h:41: sorry, unimplemented: inlining failed in call to 
'setup_uio': function body not available
../afs/osi_vnodeops.c:1286: sorry, unimplemented: called from here
make[4]: *** [osi_vnodeops.o] Error 1
Comment 1 Maurice van der Pot (RETIRED) gentoo-dev 2005-06-30 14:30:02 UTC
OpenAFS needs a developer to take up maintenance.
Comment 2 Martin Mokrejš 2005-07-02 02:26:56 UTC
This happens also with openafs-1.2.13. It seems one cannot build openafs against
newer kernels. The incompatibility was introduced between linux-2.4.26-rc1 and

Watch for upstream resolution at
Comment 3 Stefaan De Roeck (RETIRED) gentoo-dev 2005-11-02 03:16:36 UTC
Upstream ticket seems to be marked as resolved, though I haven't seen a new
1.2.x release.  My guess is that they call the fix openafs-1.4.0 (out today). 
Is upgrading to 1.4.0 an option for you?  

(If you do, please take the documentation at into account,
it's an update for the gentoo guide that has not been pushed yet)
Comment 4 Stefaan De Roeck (RETIRED) gentoo-dev 2005-12-13 00:34:47 UTC
No response in a month. Marking as UPSTREAM, as a (resolved) ticket about this
issue is available there.  

I don't think I'm planning to push out a new stable 1.2.x, I think 1.4.x is the
way to go.  And noone seems to be asking for 1.2.x anyway.