Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 724070 - dev-scheme/guile-gcrypt does not respect CFLAGS
Summary: dev-scheme/guile-gcrypt does not respect CFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sergei Trofimovich
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags
  Show dependency tree
 
Reported: 2020-05-19 19:44 UTC by Agostino Sarubbo
Modified: 2020-05-22 18:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,18.07 KB, text/plain)
2020-05-19 19:44 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-19 19:44:38 UTC
This is an auto-filed bug because dev-scheme/guile-gcrypt does not respect CFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-19 19:44:46 UTC
Created attachment 640396 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-05-22 18:22:05 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4ebe40715db22f1494ee1b5d950e49b5240a4a62

commit 4ebe40715db22f1494ee1b5d950e49b5240a4a62
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-05-22 18:15:23 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-05-22 18:15:23 +0000

    dev-scheme/guile-gcrypt: add QA CFLAGS workaround, bug #724070
    
    guile does not use CFLAGS, it's a portage's false positive
    (see bug #677600).
    
    Reported-by:  Agostino Sarubbo
    Closes: https://bugs.gentoo.org/724070
    Bug: https://bugs.gentoo.org/677600
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 dev-scheme/guile-gcrypt/guile-gcrypt-0.2.1.ebuild | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)