Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 723262 - sys-boot/lilo-24.2 : fails to build with -fno-common or gcc-10
Summary: sys-boot/lilo-24.2 : fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL: https://bugs.debian.org/cgi-bin/bugre...
Whiteboard:
Keywords: PATCH
: 725724 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-15 17:23 UTC by Toralf Förster
Modified: 2021-01-06 18:04 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.65 KB, text/plain)
2020-05-15 17:24 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,96.69 KB, text/plain)
2020-05-15 17:24 UTC, Toralf Förster
Details
environment (environment,88.66 KB, text/plain)
2020-05-15 17:24 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.16 KB, application/x-bzip)
2020-05-15 17:24 UTC, Toralf Förster
Details
sys-boot:lilo-24.2:20200515-171351.log (sys-boot:lilo-24.2:20200515-171351.log,28.66 KB, text/plain)
2020-05-15 17:24 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,24.98 KB, application/x-bzip)
2020-05-15 17:24 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-15 17:23:57 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: raid.o:(.bss+0x8): multiple definition of `do_md_install'; lilo.o:(.bss+0x20): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: raid.o:(.bss+0x0): multiple definition of `md_bios'; lilo.o:(.bss+0x18): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_developer-libressl-20200513-084537

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-10.1.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7 (fallback)
  [3]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.43.1 *
The following VMs are available for generation-2:
*)	IcedTea JDK 3.15.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Fri 15 May 2020 05:05:25 PM UTC
/var/db/repos/libressl	Sat 11 Apr 2020 05:02:25 AM UTC

emerge -qpvO sys-boot/lilo
[ebuild  N    ] sys-boot/lilo-24.2  USE="-device-mapper -minimal -pxeserial -static"
Comment 1 Toralf Förster gentoo-dev 2020-05-15 17:24:00 UTC
Created attachment 639376 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-15 17:24:03 UTC
Created attachment 639378 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-15 17:24:06 UTC
Created attachment 639380 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-15 17:24:08 UTC
Created attachment 639382 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-15 17:24:11 UTC
Created attachment 639384 [details]
sys-boot:lilo-24.2:20200515-171351.log
Comment 6 Toralf Förster gentoo-dev 2020-05-15 17:24:15 UTC
Created attachment 639386 [details]
temp.tbz2
Comment 7 Joshua Kinard gentoo-dev 2020-07-31 01:37:02 UTC
*** Bug 725724 has been marked as a duplicate of this bug. ***
Comment 8 Yuriy Dmitriev 2020-09-30 10:39:52 UTC
Confirm. Not compiled.
Waiting patch.

Now exists alot of equipment without efi.
Comment 9 Joshua Kinard gentoo-dev 2020-11-08 03:16:27 UTC
The patch from Debian works.  I've tested against lilo-24.2 by recompiling w/ gcc-10.2 on my dev box, which reboots w/o a hitch.  I've got fixed ebuilds for 24.2 and 24.1 (which is also fixed up for EAPI7, too).

@chainsaw, okay to commit?
Comment 10 Tony Vroon gentoo-dev 2020-11-08 10:21:48 UTC
(In reply to Joshua Kinard from comment #9)
> The patch from Debian works.  I've tested against lilo-24.2 by recompiling
> w/ gcc-10.2 on my dev box, which reboots w/o a hitch.  I've got fixed
> ebuilds for 24.2 and 24.1 (which is also fixed up for EAPI7, too).
> 
> @chainsaw, okay to commit?

Yes, please go ahead. There's an NVME patch in the tracker too if you're able to combine that and build-test. I am struggling to find non-EFI boxes these days... sorry for the delays.
Comment 11 Joshua Kinard gentoo-dev 2020-11-08 20:30:24 UTC
(In reply to Tony Vroon from comment #10)
> (In reply to Joshua Kinard from comment #9)
> > The patch from Debian works.  I've tested against lilo-24.2 by recompiling
> > w/ gcc-10.2 on my dev box, which reboots w/o a hitch.  I've got fixed
> > ebuilds for 24.2 and 24.1 (which is also fixed up for EAPI7, too).
> > 
> > @chainsaw, okay to commit?
> 
> Yes, please go ahead. There's an NVME patch in the tracker too if you're
> able to combine that and build-test. I am struggling to find non-EFI boxes
> these days... sorry for the delays.

I already committed and closed the bug for NVME support.  My current dev box boots off of a small Optane M.2 NVME.  I think the board is running in EFI mode, but I probably flipped on the legacy CSM/BIOS stuff to get the SAS adapter to play nice.  I lose track of it all these days on the x86-side of the house.
Comment 12 Larry the Git Cow gentoo-dev 2020-11-08 20:51:10 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6f94f3741de3665ae7b1d32d52438c52cd366cf0

commit 6f94f3741de3665ae7b1d32d52438c52cd366cf0
Author:     Joshua Kinard <kumba@gentoo.org>
AuthorDate: 2020-11-08 20:50:35 +0000
Commit:     Joshua Kinard <kumba@gentoo.org>
CommitDate: 2020-11-08 20:51:03 +0000

    sys-boot/lilo: EAPI update and gcc-10 fix
    
    Update lilo-24.1's ebuild to EAPI7 and add a patch from Debian to fix
    compilation issues with gcc-10.x and up to both lilo-24.1 and lilo-24.2.
    
    Closes: https://bugs.gentoo.org/723262
    Signed-off-by: Joshua Kinard <kumba@gentoo.org>
    Package-Manager: Portage-3.0.9, Repoman-3.0.2

 sys-boot/lilo/files/lilo-24.x-fix-gcc-10.patch | 51 ++++++++++++++++++++++++++
 sys-boot/lilo/lilo-24.1.ebuild                 | 10 +++--
 sys-boot/lilo/lilo-24.2.ebuild                 |  1 +
 3 files changed, 59 insertions(+), 3 deletions(-)