Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 723164 - dev-lua/lualdap does not respect LDFLAGS
Summary: dev-lua/lualdap does not respect LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2020-05-15 07:17 UTC by Agostino Sarubbo
Modified: 2020-12-01 23:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.92 KB, text/plain)
2020-05-15 07:17 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-15 07:17:41 UTC
This is an auto-filled bug because dev-lua/lualdap does not respect LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to see this bug as an hint to hide the QA warning where is not possible to respect LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-15 07:17:49 UTC
Created attachment 639150 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-12-01 23:54:34 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=03a1bee2fc2e190d8ba765bd46cdb1f95caa3804

commit 03a1bee2fc2e190d8ba765bd46cdb1f95caa3804
Author:     Conrad Kostecki <conikost@gentoo.org>
AuthorDate: 2020-12-01 23:44:17 +0000
Commit:     Conrad Kostecki <conikost@gentoo.org>
CommitDate: 2020-12-01 23:53:54 +0000

    dev-lua/lualdap: bump to version 1.2.5
    
    This version switches back to a more active repo.
    Thanks to the work of winterheart with some changes.
    
    Closes: https://bugs.gentoo.org/693540
    Closes: https://bugs.gentoo.org/723164
    Closes: https://github.com/gentoo/gentoo/pull/17491
    Package-Manager: Portage-3.0.9, Repoman-3.0.2
    Signed-off-by: Conrad Kostecki <conikost@gentoo.org>

 dev-lua/lualdap/Manifest             |  1 +
 dev-lua/lualdap/lualdap-1.2.5.ebuild | 58 ++++++++++++++++++++++++++++++++++++
 dev-lua/lualdap/metadata.xml         |  7 +++++
 3 files changed, 66 insertions(+)