Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 723072 - dev-lang/gforth does not respect CFLAGS/LDFLAGS
Summary: dev-lang/gforth does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sergei Trofimovich
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: cflags ldflags
  Show dependency tree
 
Reported: 2020-05-14 15:57 UTC by Agostino Sarubbo
Modified: 2021-07-05 07:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,57.55 KB, text/plain)
2020-05-14 15:57 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-14 15:57:01 UTC
This is an auto-filled bug because dev-lang/gforth does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches" and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to set also FFLAGS and FCFLAGS or just see this bug as an hint to hide the QA warning where is not possible to respect CFLAGS/LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-14 15:57:11 UTC
Created attachment 639036 [details]
build.log

build log and emerge --info
Comment 2 Sergei Trofimovich gentoo-dev 2020-05-22 18:47:10 UTC
gforth calls libtool from within gforth. Not sure if there is a way to pass through CFLAGS/LDFLAGS. Might be tricky to fix.
Comment 3 Larry the Git Cow gentoo-dev 2021-07-05 07:26:07 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9731c2b3a814ecc2a11a89c3b5ce13a36121987b

commit 9731c2b3a814ecc2a11a89c3b5ce13a36121987b
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2021-07-05 07:24:22 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2021-07-05 07:24:22 +0000

    dev-lang/gforth: pass CFLAGS/LDFLAGS through
    
    Reported-by: Agostino Sarubbo
    Closes: https://bugs.gentoo.org/723072
    Package-Manager: Portage-3.0.20, Repoman-3.0.3
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 .../gforth/files/gforth-0.7.3-CFLAGS-LDFLAGS.patch | 27 +++++++++
 dev-lang/gforth/gforth-0.7.3-r2.ebuild             | 66 ++++++++++++++++++++++
 2 files changed, 93 insertions(+)