Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 723018 - sys-apps/hwloc-2.1.0: doins failed on prefix; FileNotFoundError: ... hwloc-dump-hwdata.service
Summary: sys-apps/hwloc-2.1.0: doins failed on prefix; FileNotFoundError: ... hwloc-du...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Cluster Team
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2020-05-14 14:04 UTC by Jan Breig
Modified: 2020-05-17 10:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,161.08 KB, text/x-log)
2020-05-14 14:04 UTC, Jan Breig
Details
ebuild patch (ebuild-diff.diff,238 bytes, patch)
2020-05-14 14:04 UTC, Jan Breig
Details | Diff
emerge --info (emerge-info,5.98 KB, text/plain)
2020-05-14 14:05 UTC, Jan Breig
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Breig 2020-05-14 14:04:12 UTC
The installation of hwloc-2.1.0 fails on prefix. Other versions work fine.

Error is:
FileNotFoundError: [Errno 2] No such file or directory: b'/data/gentoo64/var/tmp/portage/sys-apps/hwloc-2.1.0/image/usr/share/hwloc/hwloc-dump-hwdata.service'

The issue is the ${D} variable in ebuild line 81/82.
Changing it to ${ED} fixes the error (see attached diff).

Reproducible: Always
Comment 1 Jan Breig 2020-05-14 14:04:37 UTC
Created attachment 638978 [details]
build.log
Comment 2 Jan Breig 2020-05-14 14:04:59 UTC
Created attachment 638980 [details, diff]
ebuild patch
Comment 3 Jan Breig 2020-05-14 14:05:20 UTC
Created attachment 638982 [details]
emerge --info