Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722664 - =dev-java/icedtea-3.16.0 fails to compile
Summary: =dev-java/icedtea-3.16.0 fails to compile
Status: RESOLVED DUPLICATE of bug 707740
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-12 10:26 UTC by Dan Goodliffe
Modified: 2020-05-12 13:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log.xz,190.15 KB, application/x-xz)
2020-05-12 10:27 UTC, Dan Goodliffe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Goodliffe 2020-05-12 10:26:22 UTC
Compilation appears to complete, at least in part:

Finished building OpenJDK for target 'images'

But fails shortly afterwards with:
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f5495bae0c2, pid=32913, tid=0x00007f54501eb700
#
# JRE version: OpenJDK Runtime Environment (8.0_252-b09) (build 1.8.0_252-b09)
# Java VM: OpenJDK 64-Bit Server VM (25.252-b09 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea 3.16.0
# Distribution: Gentoo Base System release 2.7, package Gentoo icedtea-3.16.0
# Problematic frame:
# V  [libjvm.so+0x8670c2]  Node::Node(unsigned int)+0x22
#
# Core dump written. Default location: /tmp/portage/dev-java/icedtea-3.16.0/work/icedtea-3.16.0/core or core.32913
#
# An error report file with more information is saved as:
# /tmp/portage/dev-java/icedtea-3.16.0/work/icedtea-3.16.0/hs_err_pid32913.log
[thread 139999758505728 also had an error]

[error occurred during error reporting , id 0xb]

#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   https://icedtea.classpath.org/bugzilla
#
/bin/sh: line 2: 32913 Aborted                 (core dumped) /tmp/portage/dev-java/icedtea-3.16.0/work/icedtea-3.16.0/openjdk.build-boot/images/j2sdk-image/bin/java -cp /tmp/portage/dev-java/icedtea-3.16.0/work/icedtea-3.16.0/test/cryptocheck.build TestCryptoLevel

Will attach full build log.

Reproducible: Always

Steps to Reproduce:
1. emerge icedtea



$ emerge --info
Portage 2.3.99 (python 3.7.7-final-0, default/linux/amd64/17.0/desktop/plasma/systemd, gcc-10.1.0, glibc-2.31-r2, 5.6.11-gentoo x86_64)
=================================================================
System uname: Linux-5.6.11-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700_CPU_@_3.40GHz-with-gentoo-2.7
KiB Mem:    32774444 total,   9274072 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of repository gentoo: Tue, 12 May 2020 08:35:15 +0000
Head commit of repository gentoo: 73733d9700a16a16be2bf8df2544afe29627be8e

sh bash 5.0_p17
ld GNU ld (Gentoo 2.34 p1) 2.34.0
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
ccache version 3.7.9 [enabled]
app-shells/bash:          5.0_p17::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.2::gentoo
dev-lang/python:          2.7.18::gentoo, 3.6.10-r2::gentoo, 3.7.7-r2::gentoo, 3.8.2-r2::gentoo
dev-util/ccache:          3.7.9::gentoo
dev-util/cmake:           3.17.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2::gentoo
sys-devel/binutils:       2.34::gentoo
sys-devel/gcc:            7.4.0-r2::gentoo, 10.1.0::gentoo
sys-devel/gcc-config:     2.2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-git-pull-extra-opts: --depth 1000

Octal
    location: /home/dang/work/portage
    masters: gentoo

RandomLAN
    location: /home/randomdan/dev/portage
    masters: gentoo

dotnet
    location: /var/lib/layman/dotnet
    masters: gentoo
    priority: 50

jm-overlay
    location: /var/lib/layman/jm-overlay
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE linux-fw-redistributable no-source-code vim.org MSttfEULA free-noncomm CC-Sampling-Plus-1.0 PUEL FESTIVAL mysql_fdw"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=native -pipe -fno-stack-protector"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O3 -march=native -pipe -fno-stack-protector"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://portage.randomdan.homeip.net/ http://mirrorsearch.randomdan.homeip.net/ http://distfiles.gentoo.org/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -O3 -march=native -pipe"
LINGUAS="en en_GB"
MAKEOPTS="-j6 -l6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tmp"
USE="X a52 acl acpi activities alsa amd64 apng autoshutdown autoupdate bash-completion berkdb branding bzip2 c++0x cairo caps cdda cddb clang cli cryptsetup cscope css curl custom-cflags custom-optimization cxx dbus declarative device-mapper dot dri dts dv dvb dvd dvdr emboss encode exif fam ffmpeg firmware flac fontconfig frei0r fuse gallium gcrypt gdbm gif git glib gnome-keyring gnutls gold gpm graphviz grub gtk hpn http2 hwaccel iconv icu imagemagick inspector introspection ipv6 ithreads javascript jemalloc jit jpeg jpeg2k json jumbo-build kipi kwallet lame lcms ldap libkms libnotify libtirpc lightning llvm lm-sensors lvm lzma lzo mad man markdown minizip mng mp3 mp4 mpeg mpm-prefork mtp mysql ncurses network network-cron nls nohourlyupdate nptl nscd nuv odbc offensive offload ogg openexr opengl openmp pam pango pch pcre pcre-jit pcre16 pcre32 pdf perl plasma png policykit postgres postproc ppds python qml qt5 readline rtmp samba savedconfig seccomp secure-delete silc smp sndfile spell split-usr sqlite ssh ssl startup-notification svg symlink syslog system-boost system-cairo system-cmark system-crontab system-ffmpeg system-harfbuzz system-heimdal system-icu system-jpeg system-jsoncpp system-libevent system-libmspack system-libs system-libvpx system-libyaml system-llvm system-lua system-qemu system-seabios system-sqlite system-uulib system-wide systemd taglib tcpd threads thumbnail tiff truetype udev udisks unicode upower usb user-session uuid vim-pager vim-syntax vlc vorbis widgets winbind wxwidgets x264 xattr xcb xml xmp xv xvfb xvid zip zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="macro actions alias auth_basic authn_alias authn_anon authn_core authn_dbm authn_file authz_core authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir env expires ext_filter file_cache filter headers include info log_config logio mime mime_magic negotiation rewrite setenvif socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias proxy proxy_http cache_socache cache_disk remoteip" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python3_7" RUBY_TARGETS="ruby27" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Dan Goodliffe 2020-05-12 10:27:18 UTC
Created attachment 638416 [details]
build.log
Comment 2 Sam James archtester gentoo-dev Security 2020-05-12 13:26:14 UTC

*** This bug has been marked as a duplicate of bug 707740 ***