Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722568 - net-analyzer/chaosreader-0.96: Can't locate Net/DNS/Packet.pm in @INC (tree clean)
Summary: net-analyzer/chaosreader-0.96: Can't locate Net/DNS/Packet.pm in @INC (tree c...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: https://github.com/brendangregg/Chaos...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-12 01:49 UTC by Anton Bolshakov
Modified: 2020-09-30 14:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Bolshakov 2020-05-12 01:49:44 UTC
bash$ chaosreader 

Can't locate Net/DNS/Packet.pm in @INC (you may need to install the Net::DNS::Packet module) (@INC contains: /etc/perl /usr/local/lib64/perl5/5.30.1/x86_64-linux /usr/local/lib64/perl5/5.30.1 /usr/lib64/perl5/vendor_perl/5.30.1/x86_64-linux /usr/lib64/perl5/vendor_perl/5.30.1 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.30.1/x86_64-linux /usr/lib64/perl5/5.30.1) at /usr/bin/chaosreader line 335.
BEGIN failed--compilation aborted at /usr/bin/chaosreader line 335.


dev-perl/Net-DNS may be missing, need to be investigated


 4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r8::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.asia.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes

local-overlay
    location: /var/db/overlays/local
    masters: gentoo
    priority: 0

pentoo
    location: /var/db/overlays/pentoo-overlay
    sync-type: git
    sync-uri: https://github.com/pentoo/pentoo-overlay
    masters: gentoo

steam-overlay
    location: /var/db/overlays/steam-overlay
    sync-type: git
    sync-uri: https://github.com/anyc/steam-overlay.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -frecord-gcc-switches"
DISTDIR="/usr/portage/distfiles"
Comment 1 Michael Mair-Keimberger (iamnr3) 2020-05-19 18:52:45 UTC
Thanks for the report.
Yes, the dependency seems to be needed. However, even with the dependency installed i still get errors like below:
x3 /home/ai # chaosreader 
syntax error at /usr/bin/chaosreader line 4282, near "if"
syntax error at /usr/bin/chaosreader line 4285, near "else"
syntax error at /usr/bin/chaosreader line 4341, near "}"
Can't redeclare "my" in "my" at /usr/bin/chaosreader line 4357, near "my"
syntax error at /usr/bin/chaosreader line 4490, near "}"
Can't redeclare "my" in "my" at /usr/bin/chaosreader line 4497, near "my"
syntax error at /usr/bin/chaosreader line 4586, near "}"
Can't redeclare "my" in "my" at /usr/bin/chaosreader line 4595, near "my"
syntax error at /usr/bin/chaosreader line 5151, near "}"
Can't redeclare "my" in "my" at /usr/bin/chaosreader line 5162, near "my"
/usr/bin/chaosreader has too many errors

Unfortunately my perl skills are pretty much non-exists so it's pretty out of my scope to fix this. I'll ask upstream and hope it can be fixed.
Comment 2 Michael Mair-Keimberger (iamnr3) 2020-05-19 19:09:41 UTC
I've made a issue on the github page, let's see what the dev can do here.
I guess it's related to the newer perl version (5.30). Unfortunately i haven't used chaosreader for a long time which is why i can't say for sure.

https://github.com/brendangregg/Chaosreader/issues/11
Comment 3 Michael Mair-Keimberger (iamnr3) 2020-09-19 16:37:08 UTC
Hi,

I'm going to remove myself as maintainer of this software (see [1]). I haven't used it for a long time and because of this bug i couldn't even use it.

Unfortunately i also haven't got any response from upstream, which is why i consider this software as tree clean candidate.

[1] https://github.com/gentoo/gentoo/pull/17604
Comment 4 Anton Bolshakov 2020-09-22 01:22:34 UTC
I agree that software is dead. Please open another bug report if you care
Comment 5 Jonas Stein gentoo-dev 2020-09-30 14:27:13 UTC
reopening, because it is not solved.
Upstream seems inactive, we should tree clean, if it is unusable.
Comment 6 Anton Bolshakov 2020-09-30 14:40:35 UTC
It is unusable and dead. Please open a separate bug for cleaning