Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722384 - app-misc/ttyload does not respect CFLAGS/LDFLAGS
Summary: app-misc/ttyload does not respect CFLAGS/LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrice Clement
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qa-cflags ldflags
  Show dependency tree
 
Reported: 2020-05-11 07:28 UTC by Agostino Sarubbo
Modified: 2020-06-03 20:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.93 KB, text/plain)
2020-05-11 07:29 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-11 07:28:52 UTC
This is an auto-filled bug because app-misc/ttyload does not respect CFLAGS/LDFLAGS.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches" and LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0".
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-11 07:29:01 UTC
Created attachment 637984 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-06-03 20:54:11 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=514545c76bff11a20835b43ce8e2b53c4a110ea5

commit 514545c76bff11a20835b43ce8e2b53c4a110ea5
Author:     Patrice Clement <monsieurp@gentoo.org>
AuthorDate: 2020-06-03 20:21:52 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2020-06-03 20:54:05 +0000

    app-misc/ttyload: honor CC, CFLAGS and LDFLAGS.
    
    Closes: https://bugs.gentoo.org/722384
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 app-misc/ttyload/ttyload-0.5.3.ebuild | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)