Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722340 - app-laptop/pbbuttonsd calls ar directly
Summary: app-laptop/pbbuttonsd calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PPC Porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-11 07:13 UTC by Agostino Sarubbo
Modified: 2021-02-20 14:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,19.19 KB, text/plain)
2020-05-11 07:13 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-11 07:13:42 UTC
This is an auto-filled bug because app-laptop/pbbuttonsd calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-11 07:13:51 UTC
Created attachment 637870 [details]
build.log

build log and emerge --info
Comment 2 Jakov Smolic 2021-02-20 14:07:24 UTC
Fixed in 7f9685828644dce80dd8afabe1a885a6b467718b

commit 7f9685828644dce80dd8afabe1a885a6b467718b
Author: Sergei Trofimovich <slyfox@gentoo.org>
Date:   Sun Dec 27 11:01:09 2020 +0000

    app-laptop/pbbuttonsd: honor user's AR setting

    Package-Manager: Portage-3.0.12, Repoman-3.0.2
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>