Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722338 - app-misc/ondir calls cc directly
Summary: app-misc/ondir calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-11 07:12 UTC by Agostino Sarubbo
Modified: 2020-06-21 07:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,7.44 KB, text/plain)
2020-05-11 07:12 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-11 07:12:40 UTC
This is an auto-filled bug because app-misc/ondir calls cc directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different CC implementation (like clang) by setting the CC variable. So this issue has been reproduced by setting the CC variable to x86_64-pc-linux-gnu-gcc and by removing the /usr/bin/cc - /usr/bin/gcc binaries.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-11 07:12:49 UTC
Created attachment 637868 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-06-21 07:54:58 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a6e815bba4145f5f072d8ddd655539060209edea

commit a6e815bba4145f5f072d8ddd655539060209edea
Author:     Patrice Clement <monsieurp@gentoo.org>
AuthorDate: 2020-06-21 07:45:03 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2020-06-21 07:54:52 +0000

    app-misc/ondir: honour CFLAGS, LD and LDFLAGS.
    
    Closes: https://bugs.gentoo.org/722338
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 app-misc/ondir/ondir-0.2.4.ebuild | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)