Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722136 - net-mail/email-3.1.3 : /.../ld: addr_parse.o:(.bss+<snip>): multiple definition of Mopts; email.o:(.bss+<snip>): first defined her
Summary: net-mail/email-3.1.3 : /.../ld: addr_parse.o:(.bss+<snip>): multiple definiti...
Status: RESOLVED DUPLICATE of bug 707620
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-10 13:36 UTC by Toralf Förster
Modified: 2020-05-17 09:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.99 KB, text/plain)
2020-05-10 13:36 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,376.90 KB, text/plain)
2020-05-10 13:36 UTC, Toralf Förster
Details
environment (environment,11.21 KB, text/plain)
2020-05-10 13:36 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,43.39 KB, application/x-bzip)
2020-05-10 13:36 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.90 KB, application/x-bzip)
2020-05-10 13:36 UTC, Toralf Förster
Details
net-mail:email-3.1.3:20200510-122409.log (net-mail:email-3.1.3:20200510-122409.log,33.84 KB, text/plain)
2020-05-10 13:36 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,7.37 KB, application/x-bzip)
2020-05-10 13:36 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-10 13:36:04 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: addr_parse.o:(.bss+0x0): multiple definition of Mopts; email.o:(.bss+0x0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: addr_parse.o:(.bss+0x48): multiple definition of global_msg; email.o:(.bss+0x48): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: addr_parse.o:(.bss+0x50): multiple definition of conf_file; email.o:(.bss+0x50): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: addr_parse.o:(.bss+0x58): multiple definition of table; email.o:(.bss+0x58): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_developer-20200426-201443

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-8.3.1
 [2] x86_64-pc-linux-gnu-10.1.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python3.8
  [3]   python3.7
  [4]   python2.7 (fallback)
  [5]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.43.0
  [2]   rust-1.43.0 *
The following VMs are available for generation-2:
*)	IcedTea JDK 3.15.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sun 10 May 2020 11:36:42 AM UTC

emerge -qpvO net-mail/email
[ebuild  N    ] net-mail/email-3.1.3
Comment 1 Toralf Förster gentoo-dev 2020-05-10 13:36:07 UTC
Created attachment 637584 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-10 13:36:12 UTC
Created attachment 637586 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-10 13:36:15 UTC
Created attachment 637588 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-10 13:36:20 UTC
Created attachment 637590 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-10 13:36:24 UTC
Created attachment 637592 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-10 13:36:27 UTC
Created attachment 637594 [details]
net-mail:email-3.1.3:20200510-122409.log
Comment 7 Toralf Förster gentoo-dev 2020-05-10 13:36:30 UTC
Created attachment 637596 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-17 09:50:35 UTC

*** This bug has been marked as a duplicate of bug 707620 ***