Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722128 - net-misc/bird-2.0.7 : /.../ld: obj/.../cf-lex.o:(.bss+<snip>): multiple definition of rta_dest_names; obj/.../cf-parse.tab.o:(.bss
Summary: net-misc/bird-2.0.7 : /.../ld: obj/.../cf-lex.o:(.bss+<snip>): multiple defin...
Status: RESOLVED DUPLICATE of bug 706704
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-10 13:34 UTC by Toralf Förster
Modified: 2020-05-21 12:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.85 KB, text/plain)
2020-05-10 13:34 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,341.71 KB, text/plain)
2020-05-10 13:34 UTC, Toralf Förster
Details
environment (environment,21.21 KB, text/plain)
2020-05-10 13:34 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,25.93 KB, application/x-bzip)
2020-05-10 13:34 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,13.59 KB, application/x-bzip)
2020-05-10 13:34 UTC, Toralf Förster
Details
net-misc:bird-2.0.7:20200510-100940.log (net-misc:bird-2.0.7:20200510-100940.log,27.64 KB, text/plain)
2020-05-10 13:34 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,11.15 KB, application/x-bzip)
2020-05-10 13:34 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-10 13:34:18 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: obj/conf/cf-lex.o:(.bss+0x40): multiple definition of rta_dest_names; obj/conf/cf-parse.tab.o:(.bss+0x60): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: obj/conf/conf.o:(.bss+0x20): multiple definition of rta_dest_names; obj/conf/cf-parse.tab.o:(.bss+0x60): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: obj/filter/filter.o:(.bss+0x20): multiple definition of rta_dest_names; obj/conf/cf-parse.tab.o:(.bss+0x60): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: obj/filter/data.o:(.bss+0x0): multiple definition of rta_dest_names; obj/conf/cf-parse.tab.o:(.bss+0x60): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome_systemd-libressl-20200430-031932

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-10.1.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python3.8
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.43.1
  [2]   rust-1.43.1 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm


  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sun 10 May 2020 09:36:45 AM UTC
/var/db/repos/libressl	Sat 11 Apr 2020 05:02:25 AM UTC

emerge -qpvO net-misc/bird
[ebuild  N    ] net-misc/bird-2.0.7  USE="client -debug"
Comment 1 Toralf Förster gentoo-dev 2020-05-10 13:34:21 UTC
Created attachment 637530 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-10 13:34:23 UTC
Created attachment 637532 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-10 13:34:26 UTC
Created attachment 637534 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-10 13:34:29 UTC
Created attachment 637536 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-10 13:34:32 UTC
Created attachment 637538 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-10 13:34:34 UTC
Created attachment 637540 [details]
net-misc:bird-2.0.7:20200510-100940.log
Comment 7 Toralf Förster gentoo-dev 2020-05-10 13:34:37 UTC
Created attachment 637542 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-21 12:16:13 UTC

*** This bug has been marked as a duplicate of bug 706704 ***