Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722034 - app-crypt/scrypt calls ar directly
Summary: app-crypt/scrypt calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jakov Smolic
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-10 08:29 UTC by Agostino Sarubbo
Modified: 2020-07-18 08:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,18.14 KB, text/plain)
2020-05-10 08:30 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-10 08:29:55 UTC
This is an auto-filled bug because app-crypt/scrypt calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-10 08:30:03 UTC
Created attachment 637442 [details]
build.log

build log and emerge --info
Comment 2 Jakov Smolic 2020-07-18 08:11:47 UTC
I am able to reproduce this with the old 1.2.0 version, but the issue is not present with the 1.3.0 version. 1.2.0 version is not present in the ::gentoo tree so I am closing this bug as it is resolved in https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=06abef632bda5d80a77d5a6ec21366da5b1e9d7c