Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722030 - app-crypt/ophcrack calls ar directly
Summary: app-crypt/ophcrack calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mike Auty
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-10 08:28 UTC by Agostino Sarubbo
Modified: 2020-05-10 11:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,50.13 KB, text/plain)
2020-05-10 08:28 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-10 08:28:08 UTC
This is an auto-filled bug because app-crypt/ophcrack calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-10 08:28:17 UTC
Created attachment 637438 [details]
build.log

build log and emerge --info
Comment 2 Mike Auty gentoo-dev 2020-05-10 11:05:33 UTC
Ok, this should have been fixed in commit c0b57206a2d6.  Please report any issues, and feel free to reopen if there's a problem with it.  5:)