Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722014 - app-editors/vis calls cc directly
Summary: app-editors/vis calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Haelwenn Monnier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-10 08:17 UTC by Agostino Sarubbo
Modified: 2020-06-06 16:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,13.32 KB, text/plain)
2020-05-10 08:17 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-10 08:17:44 UTC
This is an auto-filled bug because app-editors/vis calls cc directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different CC implementation (like clang) by setting the CC variable. So this issue has been reproduced by setting the CC variable to x86_64-pc-linux-gnu-gcc and by removing the /usr/bin/cc - /usr/bin/gcc binaries.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-10 08:17:52 UTC
Created attachment 637422 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-06-06 16:36:18 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a0615eb3242d0bea42719bea4f34fbcb75a14af5

commit a0615eb3242d0bea42719bea4f34fbcb75a14af5
Author:     Haelwenn (lanodan) Monnier <contact@hacktivis.me>
AuthorDate: 2020-06-06 16:35:37 +0000
Commit:     Joonas Niilola <juippis@gentoo.org>
CommitDate: 2020-06-06 16:36:06 +0000

    app-editors/vis: Respect CC and CFLAGS in tests
    
    Closes: https://bugs.gentoo.org/722014
    Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
    Signed-off-by: Joonas Niilola <juippis@gentoo.org>

 app-editors/vis/vis-0.5.ebuild | 3 +++
 1 file changed, 3 insertions(+)