Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 722010 - x11-wm/wmfs-201003 : fails to build with -fno-common or gcc-10
Summary: x11-wm/wmfs-201003 : fails to build with -fno-common or gcc-10
Status: RESOLVED DUPLICATE of bug 706654
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-10 07:59 UTC by Toralf Förster
Modified: 2020-05-17 13:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.40 KB, text/plain)
2020-05-10 07:59 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,288.45 KB, text/plain)
2020-05-10 07:59 UTC, Toralf Förster
Details
environment (environment,110.76 KB, text/plain)
2020-05-10 07:59 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,25.03 KB, application/x-bzip)
2020-05-10 07:59 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.52 KB, application/x-bzip)
2020-05-10 07:59 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,30.69 KB, application/x-bzip)
2020-05-10 07:59 UTC, Toralf Förster
Details
x11-wm:wmfs-201003:20200510-075634.log (x11-wm:wmfs-201003:20200510-075634.log,156.47 KB, text/plain)
2020-05-10 07:59 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-10 07:59:38 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: CMakeFiles/wmfs.dir/src/confparse/confparse.c.o:(.bss+0x0): multiple definition of `dpy'; CMakeFiles/wmfs.dir/src/confparse/util.c.o:(.bss+0x0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: CMakeFiles/wmfs.dir/src/confparse/confparse.c.o:(.bss+0x8): multiple definition of `gc'; CMakeFiles/wmfs.dir/src/confparse/util.c.o:(.bss+0x8): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib_hardened-libressl-20200502-233152

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-10.1.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python3.8 (fallback)
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.43.0 *
  [2]   rust-bin-1.43.1
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sun 10 May 2020 06:13:24 AM UTC
/var/db/repos/libressl	Sat 11 Apr 2020 05:02:25 AM UTC

emerge -qpvO x11-wm/wmfs
[ebuild  N    ] x11-wm/wmfs-201003
Comment 1 Toralf Förster gentoo-dev 2020-05-10 07:59:41 UTC
Created attachment 637406 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-10 07:59:43 UTC
Created attachment 637408 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-10 07:59:46 UTC
Created attachment 637410 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-10 07:59:49 UTC
Created attachment 637412 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-10 07:59:51 UTC
Created attachment 637414 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-10 07:59:54 UTC
Created attachment 637416 [details]
temp.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-05-10 07:59:58 UTC
Created attachment 637418 [details]
x11-wm:wmfs-201003:20200510-075634.log
Comment 8 Jeroen Roovers gentoo-dev 2020-05-17 13:40:22 UTC
I didn't fix this properly in the first instance.

*** This bug has been marked as a duplicate of bug 706654 ***