Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721914 - app-backup/tarsnap calls ar directly
Summary: app-backup/tarsnap calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Thomas Deutschmann
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-09 17:13 UTC by Agostino Sarubbo
Modified: 2020-12-22 16:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,97.25 KB, text/plain)
2020-05-09 17:13 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-09 17:13:06 UTC
This is an auto-filled bug because app-backup/tarsnap calls ar directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to x86_64-pc-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-09 17:13:14 UTC
Created attachment 637128 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-12-22 16:29:03 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bcd1e284afaeae01d6fd65d06e5e2d9f6dcc9f9c

commit bcd1e284afaeae01d6fd65d06e5e2d9f6dcc9f9c
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2020-12-22 16:24:24 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2020-12-22 16:28:59 +0000

    app-backup/tarsnap: respect AR
    
    Closes: https://bugs.gentoo.org/721914
    Package-Manager: Portage-3.0.12, Repoman-3.0.2
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 app-backup/tarsnap/files/tarsnap-1.0.39-respect-AR.patch | 14 ++++++++++++++
 app-backup/tarsnap/tarsnap-1.0.39.ebuild                 | 10 ++++++++--
 2 files changed, 22 insertions(+), 2 deletions(-)