Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721364 - sci-libs/arpack calls commands that do not exist
Summary: sci-libs/arpack calls commands that do not exist
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
: 722272 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-07 06:19 UTC by Agostino Sarubbo
Modified: 2020-07-10 18:23 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,113.43 KB, text/plain)
2020-05-07 06:19 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-07 06:19:23 UTC
This is an auto-filled bug because sci-libs/arpack calls commands that do not exist.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-07 06:19:33 UTC
Created attachment 636600 [details]
build.log

build log and emerge --info
Comment 2 François Bissey 2020-05-07 07:39:10 UTC
Took me 5 minutes to figure it out. The ebuild is missing a "\" at the end of line 37.
https://gitweb.gentoo.org/repo/gentoo.git/tree/sci-libs/arpack/arpack-3.5.0.ebuild#n37

This is really showing off in the way configure is called.
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-dependency-tracking --disable-silent-rules --docdir=/usr/share/doc/arpack-3.5.0 --htmldir=/usr/share/doc/arpack-3.5.0/html --with-sysroot=/ --libdir=/usr/lib64 --disable-static

No --with-blas=..., no --with-lapack=... and no --{en,dis}able-mpi at the end. That's because bash tries to execute that as a separate command since it is not part of the configure line.
Comment 4 Sam James gentoo-dev Security 2020-07-10 18:23:40 UTC
*** Bug 722272 has been marked as a duplicate of this bug. ***