Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721282 - app-misc/g15daemon-1.9.5.3-r13 : /.../ld: error: main.o: multiple definition of lcdlist_mutex
Summary: app-misc/g15daemon-1.9.5.3-r13 : /.../ld: error: main.o: multiple definition ...
Status: RESOLVED DUPLICATE of bug 706712
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-06 14:55 UTC by Toralf Förster
Modified: 2020-05-21 12:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.55 KB, text/plain)
2020-05-06 14:55 UTC, Toralf Förster
Details
app-misc:g15daemon-1.9.5.3-r13:20200506-145204.log (app-misc:g15daemon-1.9.5.3-r13:20200506-145204.log,25.00 KB, text/plain)
2020-05-06 14:56 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,138.78 KB, text/plain)
2020-05-06 14:56 UTC, Toralf Förster
Details
environment (environment,173.24 KB, text/plain)
2020-05-06 14:56 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.09 KB, application/x-bzip)
2020-05-06 14:56 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.65 KB, application/x-bzip)
2020-05-06 14:56 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,41.36 KB, application/x-bzip)
2020-05-06 14:56 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-06 14:55:55 UTC
x86_64-pc-linux-gnu-gcc -DG15DAEMON_BUILD -Wall -O2 -pipe -march=native -falign-functions=32:25:16 -fno-common -rdynamic -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -o g15daemon utility_funcs.o main.o linked_lists.o g15_plugins.o  -ldl -lpthread -lm -lg15render -lg15  
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: main.o: multiple definition of lcdlist_mutex
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: utility_funcs.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: main.o: multiple definition of g15lib_mutex
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: utility_funcs.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python3.8 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed 06 May 2020 01:38:59 PM UTC

emerge -qpvO app-misc/g15daemon
[ebuild  N    ] app-misc/g15daemon-1.9.5.3-r13  USE="-perl -python -static-libs" PYTHON_TARGETS="python2_7"
Comment 1 Toralf Förster gentoo-dev 2020-05-06 14:55:57 UTC
Created attachment 636500 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-06 14:56:00 UTC
Created attachment 636502 [details]
app-misc:g15daemon-1.9.5.3-r13:20200506-145204.log
Comment 3 Toralf Förster gentoo-dev 2020-05-06 14:56:04 UTC
Created attachment 636504 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-05-06 14:56:07 UTC
Created attachment 636506 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-05-06 14:56:10 UTC
Created attachment 636508 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-06 14:56:13 UTC
Created attachment 636510 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-05-06 14:56:16 UTC
Created attachment 636512 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-21 12:02:10 UTC

*** This bug has been marked as a duplicate of bug 706712 ***