Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721238 - net-libs/libbloom calls ar directly
Summary: net-libs/libbloom calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Yixun Lan
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-05-06 11:58 UTC by Agostino Sarubbo
Modified: 2020-06-01 08:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,8.01 KB, text/plain)
2020-05-06 11:58 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-05-06 11:58:41 UTC
This is an auto-filled bug because net-libs/libbloom calls ar directly.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
If you think it doesn't make sense fix these type of issues, I'd like to point out that won't be possible use a different AR implementation (like llvm-ar) by setting the AR variable. So this issue has been reproduced by setting the AR variable to aarch64-unknown-linux-gnu-ar and by removing the /usr/bin/ar binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-05-06 11:58:50 UTC
Created attachment 636422 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-06-01 07:24:27 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f7a2c4a647ebed76a49f3c68942763d767999b55

commit f7a2c4a647ebed76a49f3c68942763d767999b55
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-06-01 07:08:35 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-06-01 07:08:35 +0000

    net-libs/libbloom: respect user's AR
    
    Reported-by: Agostino Sarubbo
    Closes: https://bugs.gentoo.org/721238
    Package-Manager: Portage-2.3.100, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 net-libs/libbloom/files/libbloom-1.5-AR.patch | 11 ++++++++++
 net-libs/libbloom/libbloom-1.5-r2.ebuild      | 30 +++++++++++++++++++++++++++
 2 files changed, 41 insertions(+)
Comment 3 Yixun Lan gentoo-dev 2020-06-01 08:33:59 UTC
thanks @slyfox for helping fix this !