Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721228 - net-ftp/linksys-tftp-1.2.1-r3 : /.../ld: error: tftp.o: multiple definition of toplevel
Summary: net-ftp/linksys-tftp-1.2.1-r3 : /.../ld: error: tftp.o: multiple definition o...
Status: RESOLVED DUPLICATE of bug 707040
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-06 11:16 UTC by Toralf Förster
Modified: 2020-05-21 11:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.54 KB, text/plain)
2020-05-06 11:16 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,128.47 KB, text/plain)
2020-05-06 11:16 UTC, Toralf Förster
Details
environment (environment,73.82 KB, text/plain)
2020-05-06 11:16 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.04 KB, application/x-bzip)
2020-05-06 11:16 UTC, Toralf Förster
Details
net-ftp:linksys-tftp-1.2.1-r3:20200506-095844.log (net-ftp:linksys-tftp-1.2.1-r3:20200506-095844.log,19.92 KB, text/plain)
2020-05-06 11:16 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,20.79 KB, application/x-bzip)
2020-05-06 11:16 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-06 11:16:33 UTC
      |          fwrite
x86_64-pc-linux-gnu-gcc -o linksys-tftp -O2 -pipe -march=native  -falign-functions=32:25:16 -fno-common -I. -Dsin=sin_x main.o tftp.o tftpsubs.o -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: tftp.o: multiple definition of toplevel
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: main.o: previous definition here
collect2: error: ld returned 1 exit status
make: *** [Makefile:33: linksys-tftp] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python3.8 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed 06 May 2020 08:12:18 AM UTC

emerge -qpvO net-ftp/linksys-tftp
[ebuild  N    ] net-ftp/linksys-tftp-1.2.1-r3
Comment 1 Toralf Förster gentoo-dev 2020-05-06 11:16:36 UTC
Created attachment 636396 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-06 11:16:38 UTC
Created attachment 636400 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-06 11:16:42 UTC
Created attachment 636402 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-06 11:16:45 UTC
Created attachment 636404 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-06 11:16:48 UTC
Created attachment 636406 [details]
net-ftp:linksys-tftp-1.2.1-r3:20200506-095844.log
Comment 6 Toralf Förster gentoo-dev 2020-05-06 11:16:50 UTC
Created attachment 636408 [details]
temp.tbz2
Comment 7 Jeroen Roovers gentoo-dev 2020-05-21 11:47:23 UTC

*** This bug has been marked as a duplicate of bug 707040 ***