Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721176 - net-mail/mboxgrep-0.7.9-r1 : /.../ld: error: main.o: multiple definition of config
Summary: net-mail/mboxgrep-0.7.9-r1 : /.../ld: error: main.o: multiple definition of c...
Status: RESOLVED DUPLICATE of bug 707224
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-06 07:31 UTC by Toralf Förster
Modified: 2020-05-17 11:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.45 KB, text/plain)
2020-05-06 07:31 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,108.99 KB, text/plain)
2020-05-06 07:31 UTC, Toralf Förster
Details
environment (environment,73.12 KB, text/plain)
2020-05-06 07:31 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.93 KB, application/x-bzip)
2020-05-06 07:31 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.34 KB, application/x-bzip)
2020-05-06 07:31 UTC, Toralf Förster
Details
net-mail:mboxgrep-0.7.9-r1:20200506-030515.log (net-mail:mboxgrep-0.7.9-r1:20200506-030515.log,9.54 KB, text/plain)
2020-05-06 07:31 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,19.34 KB, application/x-bzip)
2020-05-06 07:31 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-06 07:31:09 UTC
x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native  -falign-functions=32:25:16 -fno-common  -I. -I. -c md5.c
x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native  -falign-functions=32:25:16 -fno-common  -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -o mboxgrep info.o main.o mh.o scan.o maildir.o mbox.o misc.o wrap.o getopt.o getopt1.o md5.o -lbz2 -lz  -L/usr/lib64 -lpcre
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: main.o: multiple definition of config
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: info.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: mh.o: multiple definition of config
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: info.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
  [5]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed 06 May 2020 01:11:20 AM UTC

emerge -qpvO net-mail/mboxgrep
[ebuild  N    ] net-mail/mboxgrep-0.7.9-r1
Comment 1 Toralf Förster gentoo-dev 2020-05-06 07:31:12 UTC
Created attachment 636318 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-06 07:31:14 UTC
Created attachment 636320 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-06 07:31:17 UTC
Created attachment 636322 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-06 07:31:20 UTC
Created attachment 636324 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-06 07:31:23 UTC
Created attachment 636326 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-06 07:31:25 UTC
Created attachment 636328 [details]
net-mail:mboxgrep-0.7.9-r1:20200506-030515.log
Comment 7 Toralf Förster gentoo-dev 2020-05-06 07:31:28 UTC
Created attachment 636330 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-17 11:46:33 UTC

*** This bug has been marked as a duplicate of bug 707224 ***