Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721174 - net-mail/email-3.1.3 : /.../ld: error: addr_parse.o: multiple definition of Mopts
Summary: net-mail/email-3.1.3 : /.../ld: error: addr_parse.o: multiple definition of M...
Status: RESOLVED DUPLICATE of bug 707620
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-06 07:30 UTC by Toralf Förster
Modified: 2020-05-17 09:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.45 KB, text/plain)
2020-05-06 07:30 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,103.89 KB, text/plain)
2020-05-06 07:30 UTC, Toralf Förster
Details
environment (environment,9.43 KB, text/plain)
2020-05-06 07:30 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.90 KB, application/x-bzip)
2020-05-06 07:30 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.13 KB, application/x-bzip)
2020-05-06 07:30 UTC, Toralf Förster
Details
net-mail:email-3.1.3:20200506-010614.log (net-mail:email-3.1.3:20200506-010614.log,37.39 KB, text/plain)
2020-05-06 07:31 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,6.80 KB, application/x-bzip)
2020-05-06 07:31 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-06 07:30:42 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: addr_parse.o: multiple definition of Mopts
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: email.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: addr_parse.o: multiple definition of global_msg
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: email.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
clang version 10.0.0 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/10/bin
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
  [5]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue 05 May 2020 11:10:52 PM UTC

emerge -qpvO net-mail/email
[ebuild  N    ] net-mail/email-3.1.3
Comment 1 Toralf Förster gentoo-dev 2020-05-06 07:30:45 UTC
Created attachment 636304 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-06 07:30:48 UTC
Created attachment 636306 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-06 07:30:51 UTC
Created attachment 636308 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-06 07:30:55 UTC
Created attachment 636310 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-06 07:30:58 UTC
Created attachment 636312 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-06 07:31:01 UTC
Created attachment 636314 [details]
net-mail:email-3.1.3:20200506-010614.log
Comment 7 Toralf Förster gentoo-dev 2020-05-06 07:31:03 UTC
Created attachment 636316 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-17 09:50:27 UTC

*** This bug has been marked as a duplicate of bug 707620 ***