Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721134 - sys-block/libzbc-5.5.1 : /.../ld: error: lib/.../libzbc_la-zbc_block.o: multiple definition of zbc_log_level
Summary: sys-block/libzbc-5.5.1 : /.../ld: error: lib/.../libzbc_la-zbc_block.o: multi...
Status: RESOLVED DUPLICATE of bug 707808
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick McLean
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-05 19:04 UTC by Toralf Förster
Modified: 2020-05-21 11:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.45 KB, text/plain)
2020-05-05 19:04 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,103.36 KB, text/plain)
2020-05-05 19:04 UTC, Toralf Förster
Details
environment (environment,58.15 KB, text/plain)
2020-05-05 19:04 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.88 KB, application/x-bzip)
2020-05-05 19:04 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,7.98 KB, application/x-bzip)
2020-05-05 19:04 UTC, Toralf Förster
Details
sys-block:libzbc-5.5.1:20200505-181639.log (sys-block:libzbc-5.5.1:20200505-181639.log,25.38 KB, text/plain)
2020-05-05 19:04 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,20.12 KB, application/x-bzip)
2020-05-05 19:04 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-05 19:04:36 UTC
libtool: link: x86_64-pc-linux-gnu-gcc -shared  -fPIC -DPIC  lib/.libs/libzbc_la-zbc.o lib/.libs/libzbc_la-zbc_block.o lib/.libs/libzbc_la-zbc_sg.o lib/.libs/libzbc_la-zbc_scsi.o lib/.libs/libzbc_la-zbc_ata.o lib/.libs/libzbc_la-zbc_fake.o   -Wl,--as-needed  -O2 -march=native -pthread -Wl,--version-script -Wl,./exports -Wl,-O1 -Wl,--defsym=__gentoo_check_ldflags__=0   -pthread -Wl,-soname -Wl,libzbc-5.5.1.so -o .libs/libzbc-5.5.1.so
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: lib/.libs/libzbc_la-zbc_block.o: multiple definition of zbc_log_level
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: lib/.libs/libzbc_la-zbc.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: lib/.libs/libzbc_la-zbc_block.o: multiple definition of zbc_fake_drv
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: lib/.libs/libzbc_la-zbc.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
  [5]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.252_p09 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue 05 May 2020 05:10:57 PM UTC

emerge -qpvO sys-block/libzbc
[ebuild  N    ] sys-block/libzbc-5.5.1  USE="-gtk"
Comment 1 Toralf Förster gentoo-dev 2020-05-05 19:04:38 UTC
Created attachment 636276 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-05 19:04:41 UTC
Created attachment 636278 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-05 19:04:45 UTC
Created attachment 636280 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-05 19:04:48 UTC
Created attachment 636282 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-05 19:04:51 UTC
Created attachment 636284 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-05 19:04:54 UTC
Created attachment 636286 [details]
sys-block:libzbc-5.5.1:20200505-181639.log
Comment 7 Toralf Förster gentoo-dev 2020-05-05 19:04:57 UTC
Created attachment 636288 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-21 11:51:55 UTC

*** This bug has been marked as a duplicate of bug 707808 ***