Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 721056 - media-sound/sexypsf-0.4.8 : /.../ld: error: ../PsxCounters.o: multiple definition of psxRegs
Summary: media-sound/sexypsf-0.4.8 : /.../ld: error: ../PsxCounters.o: multiple defini...
Status: RESOLVED DUPLICATE of bug 706820
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-05 07:51 UTC by Toralf Förster
Modified: 2020-08-08 13:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.87 KB, text/plain)
2020-05-05 07:52 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,84.25 KB, text/plain)
2020-05-05 07:52 UTC, Toralf Förster
Details
environment (environment,49.34 KB, text/plain)
2020-05-05 07:52 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.78 KB, application/x-bzip)
2020-05-05 07:52 UTC, Toralf Förster
Details
media-sound:sexypsf-0.4.8:20200505-050738.log (media-sound:sexypsf-0.4.8:20200505-050738.log,41.08 KB, text/plain)
2020-05-05 07:52 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-05 07:51:58 UTC
      |  ^~~~~~~~~~
x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 ../PsxBios.o ../PsxCounters.o ../PsxDma.o ../Spu.o ../PsxHw.o ../PsxMem.o ../Misc.o ../R3000A.o ../PsxInterpreter.o ../PsxHLE.o ../spu/spu.o oss.o LnxMain.o -o sexypsf -lz
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: ../PsxCounters.o: multiple definition of psxRegs
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: ../PsxBios.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: ../PsxCounters.o: multiple definition of psxNextCounter
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: ../PsxBios.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue 05 May 2020 03:40:47 AM UTC

emerge -qpvO media-sound/sexypsf
[ebuild  N    ] media-sound/sexypsf-0.4.8
Comment 1 Toralf Förster gentoo-dev 2020-05-05 07:52:01 UTC
Created attachment 636170 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-05 07:52:04 UTC
Created attachment 636172 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-05 07:52:09 UTC
Created attachment 636174 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-05 07:52:12 UTC
Created attachment 636176 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-05 07:52:15 UTC
Created attachment 636178 [details]
media-sound:sexypsf-0.4.8:20200505-050738.log
Comment 6 David Seifert gentoo-dev 2020-08-08 13:27:14 UTC

*** This bug has been marked as a duplicate of bug 706820 ***