Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 721054 - sys-block/cec-14 : /.../ld: error: linux.o: multiple definition of debug
Summary: sys-block/cec-14 : /.../ld: error: linux.o: multiple definition of debug
Status: RESOLVED DUPLICATE of bug 706974
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-05 07:51 UTC by Toralf Förster
Modified: 2020-05-17 12:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.87 KB, text/plain)
2020-05-05 07:51 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,82.89 KB, text/plain)
2020-05-05 07:51 UTC, Toralf Förster
Details
environment (environment,40.28 KB, text/plain)
2020-05-05 07:51 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.76 KB, application/x-bzip)
2020-05-05 07:51 UTC, Toralf Förster
Details
sys-block:cec-14:20200505-043549.log (sys-block:cec-14:20200505-043549.log,3.84 KB, text/plain)
2020-05-05 07:51 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,10.92 KB, application/x-bzip)
2020-05-05 07:51 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-05 07:51:36 UTC
+ x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -falign-functions=32:25:16 -fno-common -c utils.c
+ x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -o cec cec.o linux.o hba.o utils.o
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: linux.o: multiple definition of debug
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: cec.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: linux.o: multiple definition of progname
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: cec.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue 05 May 2020 03:40:47 AM UTC

emerge -qpvO sys-block/cec
[ebuild  N    ] sys-block/cec-14
Comment 1 Toralf Förster gentoo-dev 2020-05-05 07:51:39 UTC
Created attachment 636158 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-05 07:51:42 UTC
Created attachment 636160 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-05 07:51:45 UTC
Created attachment 636162 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-05 07:51:48 UTC
Created attachment 636164 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-05 07:51:50 UTC
Created attachment 636166 [details]
sys-block:cec-14:20200505-043549.log
Comment 6 Toralf Förster gentoo-dev 2020-05-05 07:51:53 UTC
Created attachment 636168 [details]
temp.tbz2
Comment 7 Jeroen Roovers gentoo-dev 2020-05-17 12:53:57 UTC

*** This bug has been marked as a duplicate of bug 706974 ***