Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 721050 - net-fs/smbtad-1.2.6 : /.../ld: error: CMakeFiles/.../configuration.c.o: multiple definition of DO_MAINTENANCE
Summary: net-fs/smbtad-1.2.6 : /.../ld: error: CMakeFiles/.../configuration.c.o: multi...
Status: RESOLVED DUPLICATE of bug 707778
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-05 07:50 UTC by Toralf Förster
Modified: 2020-05-21 11:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.86 KB, text/plain)
2020-05-05 07:50 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,63.69 KB, text/plain)
2020-05-05 07:50 UTC, Toralf Förster
Details
environment (environment,110.21 KB, text/plain)
2020-05-05 07:50 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.71 KB, application/x-bzip)
2020-05-05 07:50 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.68 KB, application/x-bzip)
2020-05-05 07:50 UTC, Toralf Förster
Details
net-fs:smbtad-1.2.6:20200504-225746.log (net-fs:smbtad-1.2.6:20200504-225746.log,27.20 KB, text/plain)
2020-05-05 07:50 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,28.17 KB, application/x-bzip)
2020-05-05 07:51 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-05 07:50:43 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: CMakeFiles/smbtad.dir/src/configuration.c.o: multiple definition of DO_MAINTENANCE
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: CMakeFiles/smbtad.dir/src/main.c.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: CMakeFiles/smbtad.dir/src/configuration.c.o: multiple definition of database_access
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: CMakeFiles/smbtad.dir/src/main.c.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Mon 04 May 2020 08:40:50 PM UTC

emerge -qpvO net-fs/smbtad
[ebuild  N    ] net-fs/smbtad-1.2.6
Comment 1 Toralf Förster gentoo-dev 2020-05-05 07:50:45 UTC
Created attachment 636134 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-05 07:50:48 UTC
Created attachment 636136 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-05 07:50:51 UTC
Created attachment 636138 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-05 07:50:53 UTC
Created attachment 636140 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-05 07:50:56 UTC
Created attachment 636142 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-05 07:50:59 UTC
Created attachment 636144 [details]
net-fs:smbtad-1.2.6:20200504-225746.log
Comment 7 Toralf Förster gentoo-dev 2020-05-05 07:51:02 UTC
Created attachment 636146 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-21 11:46:28 UTC

*** This bug has been marked as a duplicate of bug 707778 ***