Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 720988 - sci-biology/embassy-phylipnew-3.69.660 : /.../ld: error: disc.o: multiple definition of phylostates
Summary: sci-biology/embassy-phylipnew-3.69.660 : /.../ld: error: disc.o: multiple def...
Status: RESOLVED DUPLICATE of bug 706414
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Biology related packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-05-04 19:14 UTC by Toralf Förster
Modified: 2020-05-21 11:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.86 KB, text/plain)
2020-05-04 19:14 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,56.93 KB, text/plain)
2020-05-04 19:14 UTC, Toralf Förster
Details
environment (environment,101.89 KB, text/plain)
2020-05-04 19:14 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.61 KB, application/x-bzip)
2020-05-04 19:14 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,10.69 KB, application/x-bzip)
2020-05-04 19:14 UTC, Toralf Förster
Details
sci-biology:embassy-phylipnew-3.69.660:20200504-190241.log (sci-biology:embassy-phylipnew-3.69.660:20200504-190241.log,13.81 KB, text/plain)
2020-05-04 19:14 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,28.50 KB, application/x-bzip)
2020-05-04 19:14 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-05-04 19:14:07 UTC
libtool: link: x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -falign-functions=32:25:16 -fno-common -O2 -Wl,-O1 -Wl,--defsym=__gentoo_check_ldflags__=0 -o fclique clique.o disc.o phylip.o  -Wl,--as-needed -L/usr/lib -lnucleus -lacd -lajaxdb -lensembl -lajaxg -lajax -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: disc.o: multiple definition of phylostates
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: clique.o: previous definition here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: error: phylip.o: multiple definition of embossouttree
/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: clique.o: previous definition here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-abi32+64-20200503-182741

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
Available Python interpreters, in order of preference:
  [1]   python3.7 (uninstalled)
  [2]   python3.6
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
The Glorious Glasgow Haskell Compilation System, version 8.0.2

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Mon 04 May 2020 05:11:04 PM UTC

emerge -qpvO sci-biology/embassy-phylipnew
[ebuild  N    ] sci-biology/embassy-phylipnew-3.69.660  USE="-X -mysql -pdf -png -postgres -static-libs"
Comment 1 Toralf Förster gentoo-dev 2020-05-04 19:14:10 UTC
Created attachment 636042 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-05-04 19:14:13 UTC
Created attachment 636044 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-05-04 19:14:16 UTC
Created attachment 636046 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-05-04 19:14:18 UTC
Created attachment 636048 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-05-04 19:14:21 UTC
Created attachment 636050 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-05-04 19:14:24 UTC
Created attachment 636052 [details]
sci-biology:embassy-phylipnew-3.69.660:20200504-190241.log
Comment 7 Toralf Förster gentoo-dev 2020-05-04 19:14:27 UTC
Created attachment 636054 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2020-05-21 11:49:21 UTC

*** This bug has been marked as a duplicate of bug 706414 ***