Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 720316 - >=www-client/seamonkey-2.53.1: USE Flag 'clang' not in IUSE
Summary: >=www-client/seamonkey-2.53.1: USE Flag 'clang' not in IUSE
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC64 Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 723254 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-01 17:52 UTC by Marcus Comstedt
Modified: 2020-09-04 12:32 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Comstedt 2020-05-01 17:52:33 UTC
It's currently not possible to build the seamonkey-2.53.1-r1 ebuild on ppc64 (or arm).  The reason is this code in mozcoreconf-v6.eclass:

---8<---
        # Additional ARCH support
        case "${ARCH}" in
        arm | ppc64)
                # Reduce the memory requirements for linking
                if use clang ; then
                        # Nothing to do
                        :;
                elif tc-ld-is-gold; then
                        append-ldflags -Wl,--no-keep-memory
                else
                        append-ldflags -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
                fi
                ;;
---8<---

Disregarding the fact that I have 128 GB RAM in my ppc64 machine and probably don't need to "Reduce the memory requirements for linking" at all, this code requires that 'clang' is in IUSE of tha actual ebuild, which it isn't in the case of seamonkey.

Reproducible: Always

Steps to Reproduce:
1.Try to emerge =www-client/seamonkey-2.53.1-r1 on ppc64 (or arm)
2.
3.
Actual Results:  
 * ERROR: www-client/seamonkey-2.53.1-r1::gentoo failed (configure phase):
 *   USE Flag 'clang' not in IUSE for www-client/seamonkey-2.53.1-r1
 * 
 * Call stack:
 *          ebuild.sh, line  125:  Called src_configure
 *        environment, line 4634:  Called mozconfig_init
 *        environment, line 3248:  Called use 'clang'
 *   phase-helpers.sh, line  247:  Called die
 * The specific snippet of code:
 *   				die "USE Flag '${u}' not in IUSE for ${CATEGORY}/${PF}"
 * 


Expected Results:  
seamonkey is built without errors

Portage 2.3.89 (python 3.6.10-final-0, default/linux/powerpc/ppc64/17.0/64bit-userland/desktop, gcc-9.3.0, glibc-2.30-r8, 5.4.21 ppc64)
=================================================================
System uname: Linux-5.4.21-ppc64-POWER9,_altivec_supported-with-gentoo-2.6
KiB Mem:   133787648 total,  19189184 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 01 May 2020 11:30:01 +0000
Head commit of repository gentoo: fa6b5c93eb0e01d71dff2b354bb1684edad0c92e
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.33.1 p2) 2.33.1
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17-r2::gentoo, 3.6.10-r1::gentoo, 3.7.7-r1::gentoo, 3.8.2-r1::gentoo
dev-util/cmake:           3.16.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.33.1-r1::gentoo
sys-devel/gcc:            9.3.0::gentoo
sys-devel/gcc-config:     2.2.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r8::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes

zeldin
    location: /usr/local/portage
    masters: gentoo

crossdev
    location: /usr/local/portage-crossdev
    masters: gentoo
    priority: 10

java
    location: /var/lib/layman/java
    masters: gentoo
    priority: 50

pike
    location: /var/lib/layman/pike
    masters: gentoo
    priority: 50

raiagent
    location: /var/lib/layman/raiagent
    masters: gentoo
    priority: 50

waebbl
    location: /var/lib/layman/waebbl
    masters: gentoo raiagent
    priority: 50

ACCEPT_KEYWORDS="ppc64"
ACCEPT_LICENSE="@FREE"
CBUILD="powerpc64-unknown-linux-gnu"
CFLAGS="-O2 -pipe -mcpu=power9"
CHOST="powerpc64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -mcpu=power9"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="sv_SE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j50"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tmp/"
USE="X a52 aac acl alsa berkdb big-endian bluetooth branding bzip2 cairo cdda cdr ckj cli crypt cups dbus dri dts dvd dvdr elogind emboss encode exif flac fortran gdbm gif gnutls gpm gtk ibm iconv icu idn ipv6 jpeg lcms ldap libffi libnotify lua mad mng mp3 mp4 mpeg mule multitarget ncurses nis nls nptl offensive ogg opengl openmp pam pango pcre pdf png policykit ppc64 ppds qt5 readline sdl seccomp smp spell split-usr ssl startup-notification svg tcpd theora threads tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xemacs xml xv xvid zlib" ABI_PPC="64" ADA_TARGET="gnat_2018" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_PPC="altivec vsx vsx3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="fbdev radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2020-05-15 16:54:01 UTC
*** Bug 723254 has been marked as a duplicate of this bug. ***
Comment 2 Larry the Git Cow gentoo-dev 2020-05-15 16:58:17 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=05cb9b8dc15cec1ac19a10f8b700f545e8f3dec4

commit 05cb9b8dc15cec1ac19a10f8b700f545e8f3dec4
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2020-05-15 16:57:21 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2020-05-15 16:58:11 +0000

    mozcoreconf-v6.eclass: Work around missing "clang" USE flag in seamonkey
    
    Bug: https://bugs.gentoo.org/720316
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 eclass/mozcoreconf-v6.eclass | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2020-05-15 16:59:49 UTC
PLease let me know here if this bug is now fixed for you.
Comment 4 ernsteiswuerfel 2020-05-16 10:39:25 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #3)
> PLease let me know here if this bug is now fixed for you.
Yes, this issue is fixed. Thanks!

However the build now errors out with:

[...]
ERROR: --disable-skia is not supported anymore
*** Fix above errors and then restart with\
               "make -f client.mk build"
make: *** [client.mk:362: configure] Error 1
 * ERROR: www-client/seamonkey-2.53.2::gentoo failed (configure phase):
 *   emake failed
Comment 5 Marcus Comstedt 2020-05-16 11:08:47 UTC
@ernsteiswuerfel That is an unrelated issue, please file a new bug.
Comment 6 ernsteiswuerfel 2020-05-16 11:40:01 UTC
(In reply to Marcus Comstedt from comment #5)
> @ernsteiswuerfel That is an unrelated issue, please file a new bug.
Done (bug #723372).