Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 71976 - app-arch/kdar segfaults if gcc-profile set to 3.4.3
Summary: app-arch/kdar segfaults if gcc-profile set to 3.4.3
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: MATSUU Takuto (RETIRED)
Depends on:
Reported: 2004-11-21 11:51 UTC by Peter Ruskin
Modified: 2005-10-11 11:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Ruskin 2004-11-21 11:51:53 UTC
With gcc-3.4.3 kdar emerges OK but segfaults when I run it.  
Version 1.1.1 allowed me to select the archive directory before blowing 
up, 1.2.0 didn't even get that far.  Both versions left a non-intuitive 
message "Alarm clock" on the console.

After I set my gcc profile to 3.3.4 it all worked OK.

# emerge info
Portage 2.0.51-r3 (default-linux/x86/2004.2, gcc-3.4.3, glibc-, 2.6.9-gentoo-r3i686)
System uname: 2.6.9-gentoo-r3 i686 AMD Athlon(tm) XP 3200+
Gentoo Base System version 1.4.16
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-
Libtools: sys-devel/libtool-1.5.2-r5
CFLAGS="-march=athlon-xp -O2 -pipe"
CONFIG_PROTECT="/etc /sbin /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks emergemail fixpackages nostrip notitles sandboxsfperms userpriv usersandbox"
USE="3dnow S3TC X aac aalib acpi acpi4linux alsa apm arts artswrappersuid audiofile avi berkdb bitmap-fonts bzlib calendar cddb cdparanoia cdr codecs cscope cups curl curlwrappers dbase devmap divx4linux dmx doc dv dvd dvdr dvdread encode escreen esd exif faac faad fam fbcon ffmpeg flac foomaticdb ftp ggi gif gimp gimpprint gphoto2 gpm gs gstreamer gtk gtk2 gtkhtml imagemagick imlib innodb interbase iodbc java javascript jbig joystick jp2 jpeg jpeg2k junit kde libg++ libwww live lzw-tiff mad maildir mbox mikmod mime mmx mmx2 mng monkey mono motif mozcalendar moznocompose moznoirc mozsvg mp3 mpeg mysql mysqli nas ncurses network nls no_wxgtk1 nocardbus nomac nptl oav odbc oggvorbis opengl oss pam pcre pdflib perl png posix postgres ppds python qt quicktime readline rtc samba scanner sdl slang slp sox speex spell sqlite sse ssl svg tcltk tcpd tga theora tiff timidity truetype unicode usb vanilla videos vim-with-x wmf x86 xbase xine xml xml2 xmms xpm xprint xv xvid yv12 zlib linguas_en_GB.UTF8"
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2004-11-21 13:10:24 UTC
1.3.0 is out, maybe a simple bump fixes the problem
Comment 2 MATSUU Takuto (RETIRED) gentoo-dev 2004-11-22 16:30:39 UTC
1.3.0 in cvs. thanks.
Comment 3 Peter Ruskin 2004-11-23 11:12:23 UTC
It isn't fixed!  With KDar 1.3.0 compiled with gcc-3.4.2:
When opening an archive created in version 1.2.0...
Dr. Konqui says: KDar crashed and caused signal 11

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.
Using host libthread_db library "/lib/".

After setting gcc to 3.3.4 and remerging kdar-1.3.0 it works fine.
Comment 4 Gour 2004-11-28 01:03:01 UTC

>It isn't fixed!  With KDar 1.3.0 compiled with gcc-3.4.2:

I have problems in emerging kdar on amd64 and submitted bugreport (see #70249).

With kdar-1.3.0 the same situation - configure does not find qt.

Any hint?


Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-10-11 11:36:54 UTC
Closing an obsolete bug, kdar-1* is no longer in portage.