Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 719174 - dev-ml/findlib does not respect CFLAGS
Summary: dev-ml/findlib does not respect CFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Team for the ML programming language family
URL:
Whiteboard:
Keywords:
: 722358 (view as bug list)
Depends on:
Blocks: cflags
  Show dependency tree
 
Reported: 2020-04-24 06:29 UTC by Agostino Sarubbo
Modified: 2021-01-26 18:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,17.85 KB, text/plain)
2020-04-24 06:29 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-04-24 06:29:42 UTC
This is an auto-filled bug because dev-ml/findlib does not respect CFLAGS.
The issue was originally discovered on arm64, but it may be reproducible on other arches as well.
If you think that a different summary clarifies the issue better, feel free to change it.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to set CFLAGS="${CFLAGS} -frecord-gcc-switches".
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-24 06:29:52 UTC
Created attachment 634312 [details]
build.log

build log and emerge --info
Comment 2 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2020-11-28 18:17:32 UTC
*** Bug 722358 has been marked as a duplicate of this bug. ***
Comment 3 Larry the Git Cow gentoo-dev 2021-01-26 18:22:26 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cd56cae02682a6007cf51c2360d0d47351ed910a

commit cd56cae02682a6007cf51c2360d0d47351ed910a
Author:     Alfredo Tupone <tupone@gentoo.org>
AuthorDate: 2021-01-26 18:21:56 +0000
Commit:     Alfredo Tupone <tupone@gentoo.org>
CommitDate: 2021-01-26 18:22:09 +0000

    dev-ml/findlib: QA flags warning ignored
    
    Closes: https://bugs.gentoo.org/719174
    Package-Manager: Portage-3.0.13, Repoman-3.0.2
    Signed-off-by: Alfredo Tupone <tupone@gentoo.org>

 dev-ml/findlib/findlib-1.8.1-r2.ebuild | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)