Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 718912 - media-plugins/live calls g++ directly
Summary: media-plugins/live calls g++ directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-04-22 16:58 UTC by Agostino Sarubbo
Modified: 2020-06-19 15:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,11.59 KB, text/plain)
2020-04-22 16:58 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-04-22 16:58:17 UTC
This is an auto-filled bug because media-plugins/live calls g++ directly.
The issue was originally discovered on amd64, but it may be reproducible on other arches as well.
Attached build log and emerge --info.

NOTE:
To reproduce this issue you may want to temporarily move the /usr/bin/g++ binary.
Comment 1 Agostino Sarubbo gentoo-dev 2020-04-22 16:58:23 UTC
Created attachment 634108 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-06-19 15:27:52 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1e54f851d2321a899a1fb76c6eb5d77d3f9a4486

commit 1e54f851d2321a899a1fb76c6eb5d77d3f9a4486
Author:     Sam James (sam_c) <sam@cmpct.info>
AuthorDate: 2020-06-17 02:09:46 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2020-06-19 15:25:02 +0000

    media-plugins/live: respect CC/CXX
    
    Closes: https://bugs.gentoo.org/718912
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 media-plugins/live/live-2020.03.06.ebuild | 5 +++++
 1 file changed, 5 insertions(+)